===========================================
| Component | Version |
|---|---|
| LibreNMS | 24.6.0-14-g33c38a560 (2024-06-20T00:30:19+09:00) |
| DB Schema | 2024_04_29_183605_custom_maps_drop_background_suffix_and_background_version (294) |
| PHP | 8.1.2-1ubuntu2.17 |
| Python | 3.10.12 |
| Database | MariaDB 10.6.16-MariaDB-0ubuntu0.22.04.1 |
| RRDTool | 1.7.2 |
| SNMP | 5.9.1 |
| =========================================== |
[OK] Composer Version: 2.6.6
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database Schema is current
[OK] SQL Server meets minimum requirements
[OK] lower_case_table_names is enabled
[OK] MySQL engine is optimal
[OK] Database and column collations are correct
[OK] Database schema correct
[OK] MySQL and PHP time match
[OK] Active pollers found
[OK] Dispatcher Service not detected
[OK] Locks are functional
[OK] Python poller wrapper is polling
[OK] Redis is unavailable
[INFO] fping FAILURES can be ignored if running LibreNMS in a jail without ::1. You may want to test it manually: fping ::1
[FAIL] /usr/bin/fping6 could not be executed. /usr/bin/fping6 must have CAP_NET_RAW capability (getcap) or suid. Selinux exclusions may be required.
(/usr/bin/fping6: can’t create socket (must run as root?))
[OK] rrd_dir is writable
[OK] rrdtool version ok
./discovery.php -h HOSTNAME -d | ./pbin.sh
Paste endpoint: https://p.libren.ms/api/create
title:
name: noc
private: 1
expire: 0
https://p.libren.ms/view/580c58c3
./poller.php -h HOSTNAME -r -f -d | ./pbin.sh
Paste endpoint: https://p.libren.ms/api/create
title:
name: noc
private: 1
expire: 0
https://p.libren.ms/view/2aa773e2
Since we don’t currently use ping in our environment, we didn’t pay much attention to ping-related errors.
hello. Dear brothers.
When I enter a device and select the “ports” menu, I get an error page with this message “Oops, something seems to be wrong, please check librenms.log”.
This is not the case for all registered devices, some are accessible to the “ports” menu and some are not. But interestingly enough, if you select each physical interface in the dashboard of a device that does not have access to the “ports” menu, you can access the individual interface page.
I’ve been searching the community and trying different methods, but it doesn’t seem like there are any similar cases to mine, so I’m stumped.
If anyone has solved this issue, I would love to know how you solved it.
Thank you.
