Server_name is set incorrectly

Hello, I get a fix suggestion in the web server area with “Validate config”:

FAIL: server_name is set incorrectly for your webserver, update your webserver config. 192.168.100.239 parse failure (/validate/results)
 
Fix: server_name 192.168.100.239;

Even though I changed server_name in /etc/nginx/conf.d/librenms.conf, nothing changes. Is there a place in the directory structure that I need to customize too?

server {
 listen      80;
 server_name 192.168.100.239;
 root        /opt/librenms/html;
 index       index.php;
 

.validate.php itself shows no error:

[email protected]:~$ ./validate.php

Component Version
LibreNMS 22.10.0-135-g7635ace4f (2022-11-20T05:10:25+01:00)
DB Schema 2022_09_03_091314_update_ports_adsl_table_with_defaults (248)
PHP 8.1.2-1ubuntu2.8
Python 3.10.6
Database MariaDB 10.6.7-MariaDB-2ubuntu1.1
RRDTool 1.7.2
SNMP 5.9.1

===========================================

[OK] Composer Version: 2.4.4
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database Schema is current
[OK] SQL Server meets minimum requirements
[OK] lower_case_table_names is enabled
[OK] MySQL engine is optimal
[OK]
[OK] Database schema correct
[OK] MySQl and PHP time match
[OK] Active pollers found
[OK] Dispatcher Service not detected
[OK] Locks are functional
[OK] Python poller wrapper is polling
[OK] Redis is unavailable
[OK] rrd_dir is writable
[OK] rrdtool version ok

config appears to be correct
did you restart nginx after changing config ?

hello yes, with systemctl restart nginx