Server unable to read htaccess file, denying access to be safe

Tags: #<Tag:0x00007ff774c4cb38>

Hey guys I have a fresh install of Librenms on CentOs 8 with Apache,
everything looks good but I have this error:

Server unable to read htaccess file, denying access to be safe

image

This is Validate:

--------
[email protected][~]:: ./validate.php 
====================================
Component | Version
--------- | -------
LibreNMS  | 1.70.1-2-g980e4a6a2
DB Schema | 2020_11_02_164331_add_powerstate_enum_to_vminfo (191)
PHP       | 7.3.20
Python    | 3.6.8
MySQL     | 10.3.17-MariaDB
RRDTool   | 1.7.0
SNMP      | NET-SNMP 5.8
====================================

[OK]    Composer Version: 2.0.8
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database schema correct
[WARN]  IPv6 is disabled on your server, you will not be able to add IPv6 devices.
[email protected][~]:: 
-------

This is Daily

------
[email protected][~]:: ./daily.sh 
Updating to latest codebase                        OK
Updating Composer packages                         OK
Updating SQL-Schema                                OK
Updating submodules                                OK
Cleaning up DB                                     OK
Fetching notifications                             OK
Caching PeeringDB data                             OK
[email protected][~]:: 
------

This is /etc/httpd/conf.d/librenms.conf

-----
<VirtualHost *:80>
  DocumentRoot /opt/librenms/html/
  ServerName  librenms.example.com

  AllowEncodedSlashes NoDecode
  <Directory "/opt/librenms/html/">
    Require all granted
    AllowOverride All
    Options FollowSymLinks MultiViews
  </Directory>

  # Enable http authorization headers
  <IfModule setenvif_module>
    SetEnvIfNoCase ^Authorization$ "(.+)" HTTP_AUTHORIZATION=$1
  </IfModule>

  <FilesMatch ".+\.php$">
    SetHandler "proxy:unix:/run/php-fpm-librenms.sock|fcgi://localhost"
  </FilesMatch>
</VirtualHost>
-----

I found that to allow the use of the webUI I have to run the following:

chmod -R 775 /opt/librenms/html/

as such:

[email protected][~]:: chmod -R 775 /opt/librenms/html/

then I can use librenms with no problems… but now, I get this error on Validate:

-----
[email protected][~]:: ./validate.php 
====================================
Component | Version
--------- | -------
LibreNMS  | 1.70.1-2-g980e4a6a2
DB Schema | 2020_11_02_164331_add_powerstate_enum_to_vminfo (191)
PHP       | 7.3.20
Python    | 3.6.8
MySQL     | 10.3.17-MariaDB
RRDTool   | 1.7.0
SNMP      | NET-SNMP 5.8
====================================

[OK]    Composer Version: 2.0.8
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database schema correct
[WARN]  IPv6 is disabled on your server, you will not be able to add IPv6 devices.
[WARN]  Your local git contains modified files, this could prevent automatic updates.
        [FIX]: 
        You can fix this with ./scripts/github-remove
        Modified Files:
         html/.htaccess
         html/ajax_dash.php
         html/ajax_form.php
         html/ajax_list.php
         html/ajax_listports.php
         html/ajax_ossuggest.php
         html/ajax_output.php
         html/ajax_search.php
         html/ajax_table.php
         html/api_v0.php
         html/bandwidth-graph.php
         html/billing-graph.php
         html/calendar.jpg
         html/css/L.Control.Locate.min.css
         html/css/L.Control.Locate.min.css.map
          and 704 more...
[email protected][~]:: 
-----

if I then run:

 ./scripts/github-remove -d

I loose access to the webUI, and back to the beginning.

any ideas???