Smokeping Cron script outputting "There are no commands defined in the "smokeping" namespace." in NMS confs

Hi all.
I’m in the process of installing smokeping into an already deployed NMS VM Ubuntu image and am having an issue with the population of the /etc/smokeping/config.d/librenms-probes.conf and librenms-targets.conf files.

I am expecting the target and probe files to be populated by the configured targets and probes from NMS but both files contain only “There are no commands defined in the “smokeping” namespace.”

Both confs are created by an hourly cron script as per the setup guide, they are getting created as expected but the contents are not.


#! /usr/bin/env bash

sudo -u librenms /opt/librenms/lnms smokeping:generate --targets > /etc/smokeping/config.d/librenms-targets.conf
sudo -u librenms /opt/librenms/lnms smokeping:generate --probes > /etc/smokeping/config.d/librenms-probes.conf

systemctl reload smokeping > /dev/null 2<&1

I seem to have missed something but have followed the setup guide to the letter with no issues except this.

Have I get the cron script correct or is it more likely I have borked something else up?

For Reference:

There are no commands defined in the “smokeping” namespace.


There are no commands defined in the “smokeping” namespace.


@include /etc/smokeping/config.d/General
@include /etc/smokeping/config.d/Alerts
@include /etc/smokeping/config.d/Database
@include /etc/smokeping/config.d/Presentation
@include /etc/smokeping/config.d/Probes
@include /etc/smokeping/config.d/Slaves
@include /etc/smokeping/config.d/Targets


*** Probes ***

@include /etc/smokeping/config.d/librenms-probes.conf


*** Targets ***

probe = FPing

menu = Top
title = Network Latency Grapher
remark = Welcome to the SmokePing website of Insert Company Name Here.
Here you will learn all about the latency of our network.

@include /etc/smokeping/config.d/librenms-targets.conf


sendmail = /usr/sbin/sendmail
imgcache = /var/cache/smokeping/images
imgurl = …/smokeping/images
datadir = /var/lib/smokeping
piddir = /var/run/smokeping
smokemail = /etc/smokeping/smokemail
tmail = /etc/smokeping/tmail
dyndir = /var/lib/smokeping/__cgi


__cgi Local __sortercache

Relevant part of config.php

$config[‘smokeping’][‘dir’] = ‘/var/lib/smokeping’;
$config[‘smokeping’][‘pings’] = 20;
$config[‘smokeping’][‘probes’] = 2;
$config[‘smokeping’][‘integration’] = true;
$config[‘smokeping’][‘url’] = ‘smokeping/’; // If you have a specific URL or path for smokeping

Are you on master / daily? The docs changed for this:

Yes I believe so. Installed NMS using the VM Image and updating via the daily updates. After reading the change to smokeping generation, I’m starting to think I have done everything right and there is something up with how this change works.
I am unsure what to do about it though.

What was the previous cron script method for populating these confs? If that works I’d like to try it out ASAP.

Sorry to be a pain. Can anyone suggest a way forward?

I worked it out.

What a massive pain in the arse it was tracking that down. It was the system proxy having a typo in the /etc/environment config. Fixed that up and it worked like magic.

Thanks for all the help everyone…