SNMP connection fail

Hi guys

I’m no expert in Librenms or have any deep knowledge in SNMP, I guess there is a risk, I’m doing some basic fault.
I’ve done some testing in my home lab,- LibreNMS in some VM’s and different routers to monitor, mostly Mikrotik. All running fine without problems. Librenms on Ubuntu 18, done all the installing myself.

Now I’m trying to run Librenms on a DigitalOcean instance monitoring Mikrotik routers. same setups, same configurations, port opening in firewalls in both ends. Changed community name.
Packet capture on Mikrotik router shows 2-way UDP communication on port 161.

I’ve spend days troubleshooting, but it’s impossible for me to get SNMP v2 or v3 running. Adding a client in Librenms gui fails every time? Ping works fine.

I need some insight in the Librenms SNMP logic,- what’s going on?
Where in Librenms can I see the step by step success/fail communication?

Running “validate config” just show a “Fail: Time between this server and the mysql database is off Mysql time”,- I guess this can’t be a major problem?


Try snmnpwalk -v2c -c YOURCOMMUNITY host . from your DigitalOcean instance.

If that doesnt return anything, thats the problem.

Thanks very, very great TheGreatDoc :grinning:

It gave me a hint,- tried a few times,- no response on server.

It look like those Mikrotik’s are bastards, remove SNMP config, apply again. Then it worked :grinning:



I have the same problem but my snmpwalk was ok.

snmpwalk -v2c -c mysnmp x.x.x.x
SNMPv2-MIB::sysDescr.0 = STRING: Cisco IOS Software [Fuji], ASR920 Software (PPC_LINUX_IOSD-UNIVERSALK9_NPE-M), Version 16.9.5f, RELEASE SOFTWARE (fc2)
Technical Support:
Copyright © 1986-2020 by Cisco Systems, Inc.
Compiled Fri 28-Feb-20 08:00 by mc
SNMPv2-MIB::sysObjectID.0 = OID: SNMPv2-SMI::enterprises.9.1.2102
DISMAN-EVENT-MIB::sysUpTimeInstance = Timeticks: (3629598652) 420 days,