SNMP cuts in and out from Cisco ISR 4451-X to LibreNMS

cisco
Tags: #<Tag:0x00007f932700be70>

#1

A few weeks ago our ISR 4451-X Cisco Router started randomly going down in LibreNMS (Internet connectivity has been completely unaffected), only changes have been regular daily updates and additional devices being added to LibreNMS.

Processor usage, storage usage, and memory usage are normal on the Debian 9 server I run LibreNMS on as well as normal on the ISR itself. There doesn’t appear to be a pattern to the drops, sometimes it’s the middle of the night and sometimes randomly during the day.

Here is my validate output:

Component Version
LibreNMS 1.46-15-gc7152294a
DB Schema 273
PHP 7.0.30-0+deb9u1
MySQL 10.1.26-MariaDB-0+deb9u1
RRDTool 1.6.0
SNMP NET-SNMP 5.7.3

====================================

[OK] Composer Version: 1.8.0
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct

Output of ./discovery.php -h HOSTNAME -d for this device is here: https://p.libren.ms/view/d5702666

Output of ./poller.php -h HOSTNAME -r -f -d for this device is here:
https://p.libren.ms/view/5721101f

Any ideas? Any other ISR users experiencing this?


#2

Have you tried per port polling?


#3

I will give it a shot, I saw it was experimental so I avoided it before.


#4

It’s not recommended that enable globally … only for devices you are seeing slow poll times


#5

Alright this looks like it’s resolved, what I did was turn off ICMP monitoring, apparently what was happening was it was marking the device as down and not accepting new SNMP data because ping would drop for a bit. I monitor the router on it’s WAN ip so setting up a management interface internally would solve this I think, it’s on my to do list