SNMP Location / Mapping issues

Hi all.

I hope that this is the right forum to post in. If not, please feel free to redirect me. I would love to get some input to help me moving forward.
Since one week ago I have had issues adding devices to LibreNMS (it is not everyday I add devices so hard for me to say how long the problem has been pressent). They do not seem to resolve a long / lat for me.

I have always used OpenStreetmaps as Mapping engine. It has provided me with long/lat without issues.
Now is just does not work. I have even tested on a fresh Ubuntu 22.04. Still same issue.
I do not know if it is related, but when running debug on the discovery i get this in the logg
1. SQL[[1;33mselect * from locations where (location = ?) limit 1 [0;33m[“Hermes Vag 10, Vaggeryd, Sweden”][0m 0.77ms]

  • ::query() failed: DNS request failed: The domain name referenced in the query does not exist.

Has there been any changes to geolocation or what it is called? Perhaps OpenStreetMaps has changed something? I do not know what to do to test further. At the moment I have no API keys to Google, so can’t test that. Would love some help.

I would also like to ask if the issue below is a bug that I should report somewhere?
When trying Google as a Mapping Engine (Had no API key so did not help). I checked the “Attempt to Geocode Locations” box. This made my discovery fail all together. However, when I changed back to OpenStreetMaps it still failed.
I had to change back to Google, unbox the “Attempt to Geocode Locations”, then change back to OpenStreetMaps, then the discovery worked (still had issue that I did not get long/lat, but discovery worked).

I know, I’m new to this, and it’s probably something simple. But I could relly use some directions.