Snmpbulkwalk timeout

I am using a device that is slow on returning values to snmp, this device has over 1k ports
I have disabled all pooling on ports that I don’t care about and it leaves me with 68 ports.
when I look it still times out, when I look at the logs I see
Error in ports module. The process "'/usr/bin/snmpbulkwalk' '-v3' '-l' 'authPriv' '-n' "" '-a' 'SHA' '-A' 'AUTH' '-u' 'USER' '-x' 'AES' '-X' 'AES' '-OQUs' '-m' 'IF-MIB' '-M' '/opt/librenms/mibs' 'DEVICEDNSNAME:161' 'ifXEntry'" exceeded the timeout of 1200 seconds.

/opt/librenms/poller.php 13 2021-05-03 15:10:05 - 1 devices polled in 1203. secs

I have set pooling to once every 25 min in cron and adjusted the config for Datastore:RRDTool to 1500
is there a place I can adjust the snmpbulkwalk timeout?

Could you try without bulk? Some devices sadly have problems with it.

and how would you change that within libernms?

From what Vendor is that device ? You can change that in yaml or in config.php
For example:

$config[‘os’][‘junos’][‘nobulk’] = 1;

thanks, I found it after 2 min of searching.

I changed it to not run bulkwalk and again I hit the timeout

I ran ./poller.php -d -h HOST -m ports
this is the same timeout as bulkwalk
The process "'/usr/bin/snmpwalk' '-v3' '-l' 'authPriv' '-n' "" '-a' 'SHA' '-A' 'PASS' '-u' 'USER' '-x' 'AES' '-X' 'PASS' '-OQUs' '-m' 'IF-MIB' '-M' '/opt/librenms/mibs' 'HOST:161' 'ifXEntry'" exceeded the timeout of 1200 seconds.

I am working with the vendor to get this looked at SNMP on these devices is so SLOW.
but for now is there a hard coded timeout I can change?

Try snmp v2 if that helps.
You can configure snmp.exec_timeout

I did try v2 and same thing, it is something up with the device that makes it take so long, this is a new SNMP implementation, and it is half baked, I don’t think they tested it on a device in the field.
thanks for pointing to the config variable, going to double it and see if that helps.

That sounds terrible. I wish you good luck in your quest!

I want to slap the guy who though not having SNMP built into a multi million dollar network platform was a good idea.


i have the same error on librenms.log
i think the timeout came from snmpbulkwalk downloading full internet route from the router/device, for about 800.000 route
is there any option to discard the poller for downloading the full route?


You cna disable the route module @buset1974 . Theoretically, if the SNMP implementation is not too old, the route module should receive the number of route, and if this number is more than a limit (1000 by default) skip all the routes.
If the implementation is too old, LibreNMS has now way to know the number of routes before discovering all of them, which means you have to manually disable the route discovery module.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.