SOLVED: Cannot create API tokens. Error "An error occurred removing the token."

Elaborating a bit more, in the hope of getting a hint or two.

When trying to generate API access tokens, an error occurs. No previous API access have been made, and no tokens exist.

The error is displayed in web-ui, and occurs after pressing the “Generate API access token”-button, and of course selecting a user.

The error simple states “An error occurred removing the token.”

[librenms@librenms librenms]# ./validate.php

Component Version
LibreNMS 1.54-16-g01a519e
DB Schema 2019_07_03_132417_create_mpls_saps_table (139)
PHP 7.2.19
MySQL 5.5.60-MariaDB
RRDTool 1.4.8


[OK] Composer Version: 1.9.0
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct

Logs dont seem to contain anything usefull, and a I checked within mysql. Api_tokens

MariaDB [librenms]> SELECT * from api_tokens;
Empty set (0.00 sec)

This got sorted while doing a server-move where I reinstalled libreNMS

I am experiencing this exact same issue on a fresh install, what could be the issue?

was a dns issue for me

I am having same issue with the new LibreNMS box. Same error as per your screenshot. CentOS 7 and Nginx based setup. Can you let me know what you did to resolve it.

Validation is fine.