[SOLVED] Plugin not receiving POST corretly. 404 error

My instance started to behave weird about plugins.
I have a current build and some plugins integrated (most of them can be find here @ community).
For example: “WhereIsVlan, VLANs, Speedtest” and so on. They seem to work when started, but when I try to search for vlan (entering some data) I got 404 error.

POST /plugin/v1/WhereIsVLAN HTTP/1.1" 404 7812 “https://LIBRENMS/plugin/v1/WhereIsVLAN

I did not change source of any plugin, neither did any changes recently.

[email protected]:~$ ./validate.php

Component Version
LibreNMS 21.10.0-27-g6bf706eaa
DB Schema 2021_07_28_102443_plugins_add_version_and_settings (222)
PHP 7.4.14
Python 3.5.3
MySQL 10.5.12-MariaDB-1:10.5.12+maria~stretch
RRDTool 1.6.0


[OK] Composer Version: 2.1.9
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct

Thanks for your guiding me into problem.


I have run in the same case for WhereIsVlan plugin on latest stable release (21.11.0)

After a while of research - plugin was updated to match new link format: https://github.com/dubbelj/librenms-plugin-WhereIsVLAN/commit/0f84be8c61778e1ece61e834255af984d670b386

I have corrected in WhereIsVLAN.inc.php line 141 just like in commit, and it is now working again:

---$form="<form action='/plugin/p=$GLOBALS[plugin_name]' method='post'>";
+++$form="<form action='/plugin/v1/$GLOBALS[plugin_name]' method='post'>";

Hope that this will help!

1 Like

Thanks, solved!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.