Solved: Rrdcached issues


I’m trying to move to rrdcached. I’m getting red boxes for graph previews and when I go to the graphs, I’m just getting the grid, no information. I followed the instructions at

rrd version information:
systemctl status rrdcached:
rrdtool command from browser:
service stops and starts:
directory permissions:
/etc/group: librenms:x:999:www-data

I haven’t found what doesn’t have the correct permissions as everything I’ve looked into so far seems to be correct.

I turn off the rrdcached config and service and Libre resumes graphing.

RRDTool Output

ERROR: rrdcached: /opt/librenms/rrd/733-nexus-3064/mempool-cemp-22.1.rrd: Permission denied

You rrdtool graph command isn’t using rrdcached from what I can see. You’ve also moved the rrd dir to somewhere else and again the graph command isn’t using it.

You might need to set $config['rrd_dir'] to point to your new location.

1 Like

How would I fix that?

I haven’t intently changed anything relating to rrd’s storage directory. I don’t see any Libre settings directing it to a different location, so I suspect that’s not the right tree to be barking up, but then again, I’m the one with a broken install that Google hasn’t been able to help me fix. :slight_smile:

Also, as I had mentioned, if I turn off rrdcached, graphing works again.

I think I’m on to something. I think the documentation is bad.

Note my /etc/default/rrdcached. I changed that base_path to /opt/librenms/rrd/ and my graphs are no longer red. My RRDTool Output on the libre page now has the line OK u:0.18 s:0.04 r:0.22 added to the bottom. I see some lines on the graphs now, but there’s a big gap. If new data starts appearing, I’ll call it good and submit another documentation fix.

Yup, that was it.

Thanks for finding the issue and fixing.

Thanks for putting up with me while I worked on it.