Squid not graphing, but snmpwalk working

Hello Iv’e been with troubles using LibreNMS with squid,
unabled to graph my squid data using proxy if i use snmpwalk manually like this :

snmpwalk -m /usr/share/squid/mib.txt -v2c -Cc -c public .
here is my output (wich is good) :

SQUID-MIB::cacheSysVMsize.0 = INTEGER: 443184
SQUID-MIB::cacheSysStorage.0 = INTEGER: 915712
SQUID-MIB::cacheUptime.0 = Timeticks: (561407353) 64 days, 23:27:53.53

dont know why it is not graphing in the LibreNMS UI here is my discover and poller past : https://p.libren.ms/view/858938b0 and https://p.libren.ms/view/de851436#L15

Did you enabled the app in the device?

Device -> Edit -> Applications

yes, it’s enabled

Then run ./discovery.php -d -h host -m applications and check if it is detecting it correctly

https://p.libren.ms/view/5503d8ec Here it is :disappointed_relieved:

its -m applications literally.

https://p.libren.ms/view/3174c626 here, tested both before ^^ same result.

Did you setup correctly the snmp proxy? https://docs.librenms.org/Extensions/Applications/#squid

Just noticed that you are doing the walk to the port 3401 and LibreNMS does it to default port.

You must set the proxy in your snmpd.conf so it will return the info to the snmpd port and not directly to the squid snmp.

1 Like

Tank you i was dumb, it was the bad IP i binded in the proxy settings of snmpd.