Ssl certificate installation not working!I


#1

i tried to install SSL Certificate in Apache server in Ubuntu 16.04 server …i have a correct syntax under
but as i enable ssl module ( sudo a2enmod ssl) ;the site do not browse and if i revert back disabling ssl module it works as it is working.
Do i need any other configuration to change??? I followed tutorials of librenms and some other tutorials but it didn’t worked for me.

My configuration is as:

<VirtualHost *:443>
DocumentRoot /opt/librenms/html/
ServerName <mycompanydomain.com>

SSLEngine on
SSLCertificateFile /etc/ssl/certs/.crt
SSLCertificateKeyFile /etc/ssl/certs/.key
CustomLog /opt/librenms/logs/access_log combined
ErrorLog /opt/librenms/logs/error_log
AllowEncodedSlashes NoDecode
<Directory “/opt/librenms/html/”>
Require all granted
AllowOverride All
Options FollowSymLinks MultiViews


#2

Not really issue with LibreNMS… its issue with setting up SSL on apache.


#3

Ok i agree with that it’s not the issue of Libre but what about apache?? How to solve this issue??? syntax is ok, since it is wildcard certificate i have been using in another subdomain too so i am damn sure it’s not the issue of certificate… How to solve this problem? please help me in this issue


#4

What about Apache? This is not Apache support


#5

Have i said this is a apache support? We are able to install libre in apache servers so i am asking for support here. I am here because may be we can deal with it editing ‘config. php’, file otherwise i do also have sense. If you have any idea on installing and troubleshooting in apache then do support me otherwise let the other people help me.


#6

I understand that. I’m saying that you maybe better off finding answers if you google search how to setup ssl on Apache. That’s all.


#7

yeah i have searched everywhere and i think i have followed right instruction there is no warning or errors in configuration but its not work… lets hope


#8

What have you tried so far?


#9

I have given full rights to the folder where ssl certificates are kept and while checking apache configuration it says the sytanx is ok… what i missed previously was i forgot to enable ssl module;i have enable that too now… and the main thing is regarding ports, sincle ssl listen in 443 ports by default, it was not in listening state now i have made it to listen… furthermore there are no any errors now but also it’s not working… so there is no any idea what to troubleshoot now… so much confused


#10

Did you set this up? https://docs.librenms.org/Support/Performance/#http2

What you mean with “The site does not browse”? Do you get at least the login page? Blank page? Anything?