Stop Tunnel_1 alerting

Hello,

How do I get Librenms to GLOBALLY stop complaining about Tunnel_1 _2 _3… ports on Windows monitored hosts?

I added to config.php:
$config[‘bad_if_regexp’][] = “/tunnel[0-9]:/”;
$config[‘bad_if_regexp’][] = “/Tunnel[0-9]:/”;

Each windows host still has alerts for these ports being down.

Is there a way to eliminate this?

TIA!

After you added those bad interfaces in config.php did you rediscover the device?

Also, you could go to those windows servers then settings → Ports Settings → and set those interfaces to disable and ignore.

I did. How long would it take for them to go away?

Looks like you added : at the end of 09]

idk but i think that is not needed.

It should look like this?
$config[‘bad_if_regexp’][] = “/Tunnel[0-9]/”;
$config[‘bad_if_regexp’][] = “/tunnel[0-9]/”;

I think also since you have [0-9]

that it would need to be regex

$config['bad_if_regexp'][] = '/tunnel[0-9]/';

https://docs.librenms.org/#Support/Configuration/#interfaces-to-be-ignored

Also when you rediscover a device it usually runs 5 min later.

Will existing alerts, that were triggered before changes, go away or will they stay?

If they stay, can they be deleted and not just muted?

You can mute them if you like. They should eventually stop. If everything is configured correctly.

I deleted the device entirely, added it back in, getting alerts on those INT’s

Current config ignores:
$config[‘bad_if_regexp’][] = ‘/tunnel[0-9]/’;
$config[‘bad_if_regexp’][] = ‘/Tunnel[0-9]/’;

Go to settings → Ports Settings → and set those interfaces to disable and ignore.

image

Seems an inefficient way to do this. There are 100’s of servers.

https://docs.librenms.org/#Support/Configuration/#interfaces-to-be-ignored

then something is wrong with interfaces ignored, you may need to play with it.

I noticed the tunnels names had _ in them I wonder if that causing not to work?

also, you could edit the alert rule not include those servers.

Are you using the default ports up/down rule?

I am using the default rule. I thought about looking for a way to exclude port names from the rule but I am unsure how to do this.

try this,

bad_ifname_regexp

$config[‘bad_ifname_regexp’][] = ‘/tunnel[0-9]/’;

Would a better question be "Why do all my Windows servers have Tunnel_0, Tunnel_1 through Tunnel_4 ports being discovered?

All vmware virtual servers.

No clue, I’m guessing something to do with SNMP and windows on those devices. I see the same on all my Windows VM’s.

Do you get alerts about them?

I do not. I don’t use the ports up/down rule. In my environment that alert rule is useless.
I try and keep my alert rules tight to help prevent alert overload.

hmmmm… REALLY good point. Its the device I care about, and specific services. I may have gotten hung up on something not worth the time to worry about.

Thanks for pointing out the forest through the trees!

1 Like

No problem and Happy Holidays :slight_smile: