Storage alerts

Ok, time to stop beating my head against this - there’s a simple switch in here somewhere I suspect… This is a little new for me so bear with me.

Trying to get some alerting going for devices using over some thresholds and can’t seem to get it to do anything useful.

Alerting for ICMP appears to be working fine and the mail transport works as well. The actual storage numbers aren’t that important, just getting it to alert at all for anything storage related isn’t cooperating. Just for giggles, we’ll say I’m trying to alert for usage over 90% of a 1TB drive. I’ve tried setting the alert to warn using either a percentage or a byte value, and I’ve even tried setting the number to ‘silly’ at like, 50% and still nothing. What’s interesting is that when I go to capture debug info for the alerts, it says the rule matches and that it’s done something, but that’s the only place it indicates this. (I tried inverting it too just to see if anything happens). With the exception of what the reason for the alert is, the settings for the rule are the same as the icmp rule - max alerts, delay, mute, etc. etc., all known good values including transports.

Rule name: Disk Space Warning
Alert rule: storage.storage_perc_warn >= 90 OR storage.storage_perc >= 90
Alert query: SELECT * FROM devices,storage WHERE (devices.device_id = ? AND devices.device_id = storage.device_id) AND (storage.storage_perc_warn >= 90 OR storage.storage_perc >= 90)
Rule match: matches

Found 1 transports to send alerts to.
Transport: mail

When a device stops responding to a ping, I expect to see the bar at the top of the page to turn red, but this doesn’t seem to happen with storage (expected?). It does see the storage values, so if it’s at ~85% and I put a file big enough to hit 95%, the usage indicator does reflect this.

I’ve had some trouble finding useful log data and despite the debug info above, it doesn’t show anything in the event history for that device like it does when there’s a failed ping check.

I tried simplifying this as much as possible just to get something out of it, but I feel like I’m missing something obvious. It clearly is looking at the storage, but it’s like there’s a toggle somewhere for it to actually do something other than display stats with that information.

(Requested validate.php output)

Component | Version
--------- | -------
LibreNMS  | 24.4.1 (2024-04-20T07:26:51-07:00)
DB Schema | 2024_04_10_093513_remove_device_perf (291)
PHP       | 8.1.2-1ubuntu2.17
Python    | 3.10.12
Database  | MariaDB 10.6.16-MariaDB-0ubuntu0.22.04.1
RRDTool   | 1.7.2
SNMP      | 5.9.1

[OK]    Composer Version: 2.7.4
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database Schema is current
[OK]    SQL Server meets minimum requirements
[OK]    lower_case_table_names is enabled
[OK]    MySQL engine is optimal
[OK]    Database and column collations are correct
[OK]    Database schema correct
[OK]    MySQL and PHP time match
[OK]    Active pollers found
[OK]    Dispatcher Service not detected
[OK]    Locks are functional
[OK]    Python poller wrapper is polling
[OK]    Redis is functional
[OK]    rrdtool version ok
[OK]    Connected to rrdcached

I’m not sure what else to try at this point…

Well this is embarrassing (totally friggin knew it was going to be something dumb!)

“disable alerting” and ‘ignore alert tag’ were turned on.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.