Switch ports not all showing in switch view

I have only Arista switches, will focus on one for simplicity. It is running EOS-4.18.11M and is a DCS-7060CX-32S. This is a new install of LibreNMS, trying to migrate away from Observium.

  • Steps to reproduce an issue.
    I have ports on my switch that are in inventory (Overview->Inventory) but do not show up in the switch view itself (Devices->All Devices->Network->select the device). The ports are missing from the Overall traffic widget, and are also missing from the Ports tab. They are disabled except for one of them which I enabled (but it is disconnected, nothing plugged in) as I wanted to test alerting. Of course, since it is not ‘detected’, no alerts are present.

  • The output of ./validate.php pastebin


If it’s an issue with the WebUI then please consider including a screenshot and the browser version you are using.

(this shows that the inventory for missing ports shows and starts here at 18 - continues to next page, compare to below)

If you are having troubles with discovery/polling include the pastebin output of:

./discovery.php pastebin output:


./poller.php pastebin output:


i can only embed one media file per post, so here is the comparison screenshot showing the ports missing from the switch view.

(this shows that the ports do not show up in the switch view, skipping from 17 to 27)

as an aside, one pattern i noticed is that any ports that were disabled when the switch was added to LibreNMS does not show in the active port list, and still does not do so after I enable it.

I don’t have any Arista, or this issue anywhere, but does anything about it correlate to what displays on the Port Settings page?

I also note in your debug output that ports 18-26 return 0 for every interface counter stat asked of them, for example:


notPresent in discovery either - assuming this discovery debug is after enabling the port, it’s not picking it up:


Yes, I agree. For some reason the the port is not being picked up after enabling it. Hopefully someone has a clue to help.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.