Syslog not working

Hi All,

I recently installed LibreNMS with Apache on Lubuntu 18.04.
My coworker installed LibreNMS with NGINX on Lubuntu 18.04

Now I am trying to enable syslog function but it seems not working well.
I followed the described in Syslog - LibreNMS Docs

I chose rsyslog and I followed below,


If you prefer rsyslog, here are some hints on how to get it working.

Add the following to your rsyslog config somewhere (could be at the top of the file in the step below, could be in rsyslog.conf if you are using remote logs for something else on this host)

# Listen for syslog messages on UDP:514
$ModLoad imudp
$UDPServerRun 514

Create a file called something like /etc/rsyslog.d/30-librenms.conf containing:

# Feed syslog messages to librenms
$ModLoad omprog

$template librenms,"%fromhost%||%syslogfacility%||%syslogpriority%||%syslogseverity%||%syslogtag%||%$year%-%$month%-%$day% %timegenerated:8:25%||%msg%||%programname%\n"

*.* action(type="omprog" binary="/opt/librenms/syslog.php" template="librenms")

& stop

Add the following to your LibreNMS config.php file to enable the Syslog extension:

$config['enable_syslog'] = 1;

# Syslog Clean Up

Can be set inside of `config.php`

$config[‘syslog_purge’] = 30;

And I configured a router to send syslog data to my server and my coworker’s server with the same configuration(only ip addresses are different).

My libreNMS is not receiving any syslog data from the router while my coworker’s is receiving.

What should I concern for the issue?

I chose the option of syslog-ng for my installation and it’s working great. Did you validate that the port is listening on the server running a simple netstat? If it’s up, did you validate with a tcpdump that the router was sending you the data? An example of that if your interface is eth0 would be tcpdump -i eth0 port 514 , log into your router, and do something to generate a syslog, see if anything comes up.

Hi, I reinstalled my ubuntbu, libreNMS and syslog-ng. But I have a problem still. I created another post. please check the issue at Error while setting up syslog-ng. Thanks!