Temperature from AVTech 4E

snmp
Tags: #<Tag:0x00007fe22c859600>

#1

Hello. I am wondering if there is a way to fix this. I have a RoomAlert 4E, running v4.2.4 firmware so up to date, and it is correctly identified as a AVTech device, icon is correct, so it is polling properly BUT the temperatures are way off. For example, from an SNMP walk…

|.1.3.6.1.4.1.20916.1.6.1.1.1.1.0|7134|Integer|x.x.x.x:161|
|.1.3.6.1.4.1.20916.1.6.1.1.1.2.0|2186|Integer|x.x.x.x:161|
|.1.3.6.1.4.1.20916.1.6.1.1.2.1.0|Int Rack Temp|OctetString|x.x.x.x:161|
|.1.3.6.1.4.1.20916.1.6.1.2.1.1.0|2225|Integer|x.x.x.x:161|
|.1.3.6.1.4.1.20916.1.6.1.2.1.2.0|7205|Integer|x.x.x.x:161|
|.1.3.6.1.4.1.20916.1.6.1.2.1.8.0|Ambient Air|OctetString|x.x.x.x:161|

LibreNMS is reporting the temprature in the graphs to be 2168 degrees C and 2205 Degrees C but in fact the temp is 21.68 and 22.05 and from comparing it, the same is happening for Fahrenheit, it is off by 2 decimal places, which is triggering alarms.

Is there an easy way to fix this?

Install info below…
|Version|1.51-53-g9d56593a2 - Tue May 14 2019 22:13:53 GMT-0500|
|DB Schema|2019_02_10_220000_add_dates_to_fdb (132)|
|Web Server|Apache/2.4.29 (Ubuntu)|
|PHP|7.2.17-0ubuntu0.18.04.1|
|MySQL|10.1.38-MariaDB-0ubuntu0.18.04.1|
|RRDtool|1.7.0|

Thanks!

B


#3

There is a setting on your 4E called snmp precision or something…


#4

Oh man, perfect. It was called 2 digit SNMP but spot on! Thanks Murrant. Do you also know if there is a way to get LibreNMS to report the Fahrenheit temp instead of Celsius? They both come back from a walk and the only setting I can find on the 4e only changes what is displayed on ITS webpage.

B


#5

At this time, no. Use Celsius like a Man :smiley: … Just joking.

No one has contributed a way to make the webui and graphs show F. The data will always be stored as Celsius in LibreNMS.


#6

Awesome. Thanks for your help!