Troubles with applications

Hi everyone,

We have a small issue. I’ve added/enabled the bind application. Tried it with the agent and the info isn’t being graphed.
If I run the /usr/lib/check_mk_agent/local/bind command I do get output/results. But nothing in LibreNMS. Anyone any tips?

This is the oudput of validate.php:


Component Version
LibreNMS 1.36-70-gc14efbf90
DB Schema 235
PHP 7.0.27-0+deb9u1
MySQL 10.1.26-MariaDB-0+deb9u1
RRDTool 1.6.0


[OK] Database connection successful
[OK] Database schema correct

We are running Debian 9.

Kind regards,


Did you enabled the unix agent for that device?

At the moment it is enabled.

I can think of a couple of problems;

  • Firewall (did you opened port 6556?)
  • Is the “only_from” variable set in xinetd/check_mk file? And if so, is that the host your trying to connect from (your librenms host)? Also, is the disable variable set to no?
  • Can you telnet from your librenms host to the server you want to check (telnet 6556) ?
  • Is the bind file put in the correct folder (/usr/lib/check_mk_agent) and did you use the correct bind file (there is one for SMTP and one for xinetd/check_mk)?
  • What is the output if you run the file manually (as root)?
1 Like