TypeError: "t is undefined"

My world map has suddenly stopped working, all it shows are the number of noded, but the map never loads

When clicking on one of the node to show the map
I get two errors in the console saying
Error: “JSONP request to https://dev.virtualearth.net/REST/v1/Imagery/Metadata/RoadOnDemand?key=myapicodehere&include=ImageryProviders&uriScheme=https& timed out”
TypeError: “t is undefined”
I’m using firefox. With google geoloc engine
$config[‘geoloc’][‘engine’] = “google”;
$config[‘geoloc’][‘api_key’] = “myapicodehere”;
could this be due to shortage in memory?

its a bit odd that the json request is BING but the engine your using is Google, What tile provider are you expecting to be using, google?

Could be bing/google maps is unreachable or timed out or an issue with the api key,

Perhaps try access that JSON request URL in your webbrowser with the API key, see if any errors.

Could also try changing your tile provider, and check librenms.log file just incase it’s something else.

Check config.php for any other $config['geoloc']['engine'] entries

I went over my config.php (https://p.libren.ms/view/bf0873fe)
But couldnt see anything wrong here, I got a new warning in my firefox console
image . But the problem still remains, not able to load the map

Ahh just found out OSM uses bing’s aerial imagery so that explains that one.

You should see a URL being pulled [librenms install]/overview/leaflet.markercluster.js.map or [librenms install]/js/leaflet.markercluster.js.map

it could be a side affect related to https://github.com/librenms/librenms/pull/10091 , you could try set
your $config['install_dir'] to /opt/librenms or where you installed it, then the base_url should be set, so try that, and then try the stable branch as a test.

Does the world map show on a dashboard widget or url/fullscreenmap/ ?

I’m still having the same problem. I’ve tried to experiment with leaflet config, instead of using goolge. In the config it asked for a tile_url, what is it and where do I get tile_url? Is this the URL you mentioned?

$config[‘leaflet’][‘tile_url’] = ‘???’;
$config[‘map’][‘engine’] = “leaflet”;
$config[‘leaflet’][‘default_lat’] = “51.981074”;
$config[‘leaflet’][‘default_lng’] = “5.350342”;
$config[‘leaflet’][‘default_zoom’] = 8;
$config[‘leaflet’][‘group_radius’] = 1;

This is what I see

it’s the same for dashboard widget or url/fullscreenmap/

Ok I figured it out. On the server I’m working on, it’s only able to show webpages and addresses using IP and not FQDN. So that would explain why I could reach the URLs (since it FQDN). I logged into another server and the map is showing

This is now working using google engine with my api key, but when switching to OMS/leaflet, the problem still remains

My final issues is, how can I keep the map stationary, it keeps zooming out to full view every min

Ahh you had no DNS resolution?

If thats when the page refreshes, then you could try turn it off using the settings menu.

Correct, no DNS resolution. I figured it out.
Thank you