Ubuntu 17 to 18 Upgrade and PHP 7.1 to 7.2 Upgrade Problem

I took a leap and tried to update my Ubuntu host from 17.10 to 18.04 and that actually went well. I ran into trouble updating PHP from 7.1 to 7.2. It all installed okay and I got all of the modules, but something odd is happening where after the update, I validate okay, but when I browse there, it states the following:

Text version:

Missing PHP extensions. Please install and enable them on your LibreNMS server.

Here’s the validate.php output:

Component | Version
--------- | -------
LibreNMS  | 1.47-97-g1bb782b6d
DB Schema | 2019_01_16_195644_add_vrf_id_and_bgpLocalAs (131)
PHP       | 7.2.14-1+ubuntu18.04.1+deb.sury.org+1
MySQL     | 10.1.34-MariaDB-0ubuntu0.18.04.1
RRDTool   | 1.7.0
SNMP      | NET-SNMP 5.7.3
[OK]    Composer Version: 1.8.0
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database schema correct

I’ve tried to purge old versions, purge the 7.2 versions of curl and mbstring and reinstall them, and nothing has seemed to work after reboots and apache service restarts, etc.

running the following shows the modules:
php --ini



Needless to say, I’m a little bit at a loss and would love some help here.


(Edits for formatting)

The CLI PHP has curl and mbstring extensions enabled. You posted an error from the webui, which is either php-fpm or mod-php. You’ll need to enable the extensions there. (or maybe just restart that php-fpm or apache httpd)

1 Like

Ah, I found the problem. The modules were enabled in fpm after all, but I forgot to disable the old php version in apache and I think mbstring and curl are incompatible with Ubuntu 18 and were uninstalled in the upgrade.

So, while php 7.2 was enabled in apache, so was php 7.1, which it defaulted to–perhaps configurable in apache config, I’m not familiar.

I ran the following:

sudo a2dismod php7.1

And that worked for me.

Thanks @murrant. Your reply helped get me searching in the right direction of what to check for.

1 Like