Unable to access GUI post installing Librenms on CENTOS7


I have freshly installed librenms on centos 7. But I am not able to access GUI:

Looks like something is wrong with the composer:
Below is the result of ./daily.sh

Below is the result of ./validate.php:

Before installation, I have also set proxy:

export http_proxy=http://proxy:[email protected]:8080

vi /etc/yum.conf


And I have installed composer manually using the highlighted command in the below image:

Status of nginx service:

I am not sure what should I do. Any help is appreciated !

Thanks in advance !


Please help !!!
Proxy is defined inside /opt/librenms/.gitconfig file -

You haven’t followed the installation instructions.

Please run composer install --no-dev

This is the msg I get when I try to run this command -

Composer version -

You are not in the librenms directory then. Follow the instructions https://docs.librenms.org/Installation/Install-LibreNMS/

Yes , I followed these steps and when I tried installing composer on /opt/librenms, it is failing (may be because of the proxy)

so I followed the steps given in the document to install the composer manually -

But still it doesn’t work.

That is to download composer itself. Not to install packages with it

HTTP_PROXY="http://my-corp-proxy.mcdonalds" composer install --no-dev

still the same error

I coult install composer now by configuring proxy as -

export https_proxy=http://my_proxy_username:[email protected]:8x8x
export http_proxy=http://my_proxy_username:[email protected]:8x8x

and then running the composer install --no-dev

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.