Unable to change TimeZone from UTC


#1

I’ve been attempting to change my timezone from UTC to PST with no success. I changed the PHP.INI for FPM and CLI to date.timezone = America/Los_Angeles with no luck. This is located in /etc/php/7.2/.
Restarted the application as well with the same result. When trying to restart php-fpm it comes back with FAIL.

The log file shows:

[06-Dec-2018 19:49:45] ERROR: FPM initialization failed
[06-Dec-2018 19:49:46] ERROR: An another FPM instance seems to already listen on /run/php/php-fpm.sock

This is running in docker on Ubuntu 18, and the timezone shows correctly there.

====================================

Component Version
LibreNMS 1.46
DB Schema 272
PHP 7.2.12-1+ubuntu18.04.1+deb.sury.org+1
MySQL 5.6.42
RRDTool 1.7.0
SNMP NET-SNMP 5.7.3

====================================

[OK] Composer Version: 1.8.0
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[WARN] IPv6 is disabled on your server, you will not be able to add IPv6 devices.
[WARN] Your install is over 24 hours out of date, last update: Sun, 02 Dec 2018 20:48:18 +0000
[FIX]:
Make sure your daily.sh cron is running and run ./daily.sh by hand to see if there are any errors.
[WARN] Your local git branch is not master, this will prevent automatic updates.
[FIX]:
You can switch back to master with git checkout master


#2

There is no timezone error in validate output…


#3

I’m aware there is no error, but I’m providing it as it is requested for every help topic created. The issue I’m having is just changing the timezone from UTC to PST.