Unable to do a simple alert setup


I am trying to modify the classic “device down” alert to exclude our printers from this “All Devices” alert.
I tried different way but difinitely not working as I still receive alerts for our printers beeing down.
here is the last I tried:
macros.device_down = 1 AND devices.status_reason = “icmp” AND devices.device_id NOT LIKE ‘ps_%’

How the hell I can know what is the item name of what I need to match our printers?
I tried devices.device_id, i tried devices.hostname, i tried by IP with ipv4_addresses.ipv4_address, not luck.

Really not intuitive…
Please help with which value I should use to get it work.

help me please

you could try hostname or sysname

neither works.
I am still receiving alerts for those devices.

You could try disabling and re-enabling the alert.

Otherwise you can open a ‘printer’ that has alerted, click the little ‘Cog’ to the right side of the screen … click ‘Capture’, select ‘Alerts’ and then click ‘Run’

This should show you alerts being run and if they are currently matching. Not sure if that would help.

You could also put all your printers into a Device Group, and then in the Alert rule select the ‘Printers’ group and then turn on the ‘All devices except in list’ button.

1 Like

You gave me good hints. And the capture thing helps to see.
Seems I got it like that:
Rule name: Device DOWN
Alert rule: macros.device_down = 1 AND devices.status_reason = “icmp” AND devices.type != “Printer”
Alert query: SELECT * FROM devices WHERE (devices.device_id = ?) AND (devices.status = 0 && (devices.disabled = 0 && devices.ignore = 0)) = 1 AND devices.status_reason = “icmp” AND devices.type != “Printer”
Rule match: no match

I’ll see in the next days how it goes. I am crossing my fingers!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.