Unauthorized graphs not working

I don’t upgrade very often so I don’t have the actual version where it broke - They worked a couple of weeks ago, but I have since upgraded 2 servers and migrated 1 other server and they all produce the same problem.

This is the error that is produced in the browser.

This is the setup on both servers - sadly I didn’t document the last version that I saw working but it was pretty recent (~2-3 weeks back)

|Version|22.7.0-33-g3d65e722a - Sun Jul 31 2022 10:09:59 GMT-0400|
|Database Schema|2022_07_19_081224_plugins_unique_index (244)|
|Web Server|nginx/1.18.0|
|Database|MariaDB 10.5.15-MariaDB-0+deb11u1|

Still broken as of Aug 14th.


If I open a new tab and log into librenms, I can then go back to my custom dashboard server and refresh and the graph appears. But if I log out librenms it will go back to producing the error.

I found an old test install that is running


and it works as expected. Is there anyway for me to step through the release versions to see where it breaks? Doing this via git clone/pull (only familiar with the very basics of git)?
I know I might have to fix/update some dependencies manually after doing this.

Just looking for a direction to go in.

You could use git bisect to find what commit broke it. If you are on latest commit you can do something like:

$ git bisect start
$ git bisect bad
$ git bisect good 22.4.0

Which will basically checkout a commit and ask you if it’s good or bad (working or broken)
You reply with git bisect good or git bisect bad until there is no commit left to test.

Thank you, just one revision back and they work again.

Unauthorized graphs work fine on release 22.6.0-19-g24fc12722

I rolled back my installs to 22.6.0 - hopefully this will be resolved in a future release.

Hmm, if unauth graphs is enabled. Full access is granted right?

They last worked in version 22.6.0

They do not work in 22.7.0 with unauthorized graphs enabled in config…

EDIT - I see it is marked as fixed in 22.8.0, Thank you.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.