Unifi Switch 24 POE detected as Linux

Hi!
Thank you for a fantastic product. I ran into some issues when adding my Ubiquiti UniFi Switch 24 POE Switch. It’s detected as linux but my Unifi AP works fine.

Steps to reproduce an issue

Add a Ubiquiti UniFi Switch 24 POE Switch to LibreNMS.

./validate.php

Component | Version
--------- | -------
LibreNMS  | 1.66
DB Schema | 2020_08_28_212054_drop_uptime_column_outages (173)
PHP       | 7.3.21
Python    | 3.8.5
MySQL     | 10.4.14-MariaDB-1:10.4.14+maria~focal
RRDTool   | 1.7.2
SNMP      | NET-SNMP 5.8
====================================

[OK]    Installed from the official Docker image; no Composer required
[OK]    Database connection successful
[OK]    Database schema correct
[WARN]  IPv6 is disabled on your server, you will not be able to add IPv6 devices.
[WARN]  Updates are managed through the official Docker image

Discovery:

https://p.libren.ms/view/9e1ada8a

Poller:

https://p.libren.ms/view/0c76f55d

Any ideas would be super welcome!

Ps. Wow, you really made it easy to report issues!

Im almost sure both pastes have missing info. I see the snmp requests but not the replies.

Can you check all info is in the paste?

1 Like

Thank you for your reply and sorry for my late one!

I ran it without piping to the shell script and here’s the output:
https://p.libren.ms/view/13d08311
https://p.libren.ms/view/6b37f78a

Kind regards,
Patrik

Found something here:

Seems like this is a common issue. I’ve created a ticket with Ubiquiti.

/Patrik

Updating the firmware to the latest GA release made Libre detect the switch as a Ubiquiti device but the port OIDs is still unavailable when walking the device. Got this answer from Ubiquitis third line.

Hi Patrik,

Hope you are doing well. My name is Ben and I am with the UI Tier 3 Support Team. Thank you for getting in touch with UI Support.

We have received reports that the stats are available in the v5.x beta firmware:
https://community.ui.com/questions/SNMP-interface-metrics-unavailable-on-USW-16-POE/b628cb40-47b5-4790-8a18-cc74720a5099#answer/773d28b8-5e94-4733-b77b-2efc492ee634

I recommend to wait until the Beta firmware is officially released and update your device afterwards. Unfortunately, I do not have an ETA available at the moment.

Hope that helps!

You know you’ve bought a professional product when you have to use a beta version to get SNMP monitoring. :slight_smile: