URGENT HELP - Upgrade to Ubuntu 18.04 killed LibreNMS!


#1

Hello,

I Upgraded my Ubuntu server to Ubuntu 18.04 and when the installation was complete, the server’s IP address has changed, and LibreNMS is not loading anymore.
When I’m trying to access ibreNMS interface by the new server’s IP I’m getting the following error message:

-----------------------------------------------------------------------------------------------------------------------------------------
*/ /* |-------------------------------------------------------------------------- | Register The Auto Loader |-------------------------------------------------------------------------- | | Composer provides a convenient, automatically generated class loader for | our application. We just need to utilize it! We'll simply require it | into the script here so that we don't have to worry about manual | loading any of our classes later on. It feels great to relax. | */ require __DIR__.'/../bootstrap/autoload.php'; /* |-------------------------------------------------------------------------- | Turn On The Lights |-------------------------------------------------------------------------- | | We need to illuminate PHP development, so let us turn on the lights. | This bootstraps the framework and gets it ready for use, then it | will load up this application so that we can run it and send | the responses back to the browser and delight our users. | */ $app = require_once __DIR__.'/../bootstrap/app.php'; /* |-------------------------------------------------------------------------- | Run The Application |-------------------------------------------------------------------------- | | Once we have the application, we can handle the incoming request | through the kernel, and send the associated response back to | the client's browser allowing them to enjoy the creative | and wonderful application we have prepared for them. | */ $kernel = $app->make(Illuminate\Contracts\Http\Kernel::class); $response = $kernel->handle( $request = Illuminate\Http\Request::capture() ); $response->send(); $kernel->terminate($request, $response);
---------------------------------------------------------------------------------------------------------------------------------------------

Please assist! any help will be more than welcome.
Thanks.


#2

it sounds like php isn’t installed properly

show outputs:

/opt/librenms/validate.php
/opt/librenms/daily.sh
php -v

check webserver config and also your base_url in librenms config


#3

Hi @Chas,

Thanks for your reply. appreciate it.

This is what I get when I’m running the following commands:

/opt/librenms/validate.php :

====================================

Component Version
LibreNMS 1.48.1-25-g21192a9cf
DB Schema Not Connected (0)
PHP 7.0.28-0ubuntu0.16.04.1
MySQL ?
RRDTool 1.7.0
SNMP NET-SNMP 5.7.3

====================================

[OK] Composer Version: 1.8.3
[OK] Dependencies up-to-date.
Could not connect to database, check logs/librenms.log.

/opt/librenms/daily.sh:

Could not connect to database, check logs/librenms.log.
Updating SQL-Schema OK
Cleaning up DB OK
Could not connect to database, check logs/librenms.log.

php -v:

PHP 7.0.28-0ubuntu0.16.04.1 (cli) ( NTS )
Copyright © 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright © 1998-2017 Zend Technologies
with Zend OPcache v7.0.28-0ubuntu0.16.04.1, Copyright © 1999-2017, by Zend Technologies

It looks like the database disconnected somehow,
I’ve already verified the right sql credentials on /opt/librenms/.env.

Waiting for your help.
Thanks.


#4

Did you check other related threads aswell like Upgrade ubuntu 16.04 to 18.04 - DB Issue and tried that solution?

You shouldn’t be seeing code in your browser, php isn’t working and PHP 7.0 is not supported anymore, I would look at installing php 7.2 .

Also check logs/librenms.log for any handy output


#5

THANKS A LOT @Chas !
It fixed the issue and now everything got back to normal.

You definitely saved my day :slight_smile:

Thanks!