Validate error: FAIL: Time between this server and the mysql database is off Mysql

Hello everyone,

I was wondering if anyone could help me. I have been facing this issue for few days now without any success. When I run ./validate I get this error. I have checked system clock and mariadb everything seems to be ok.

image

have almost exactly the same problem other than the local git issue
~$ ./validate.php

Component Version
LibreNMS 22.5.0-41-g3e547de95
DB Schema 2022_05_30_084932_update-app-status-length (242)
PHP 7.4.28
Python 3.9.2
MySQL 10.5.15-MariaDB-0+deb11u1
RRDTool 1.7.2
SNMP 5.9

====================================

[OK] Composer Version: 2.3.7
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database Schema is current
[OK] SQL Server meets minimum requirements
[OK] lower_case_table_names is enabled
[OK] MySQL engine is optimal
[OK]
[OK] Database schema correct
[FAIL] Time between this server and the mysql database is off
Mysql time 2022-06-11 11:11:26
PHP time 2022-06-11 12:11:26
[OK] rrd_dir is writable
[OK] rrdtool version ok
Started this morning, checked php time and mysql time and they both agree
MariaDB [(none)]> select now();
±--------------------+
| now() |
±--------------------+
| 2022-06-11 12:13:17 |
±--------------------+
1 row in set (0.000 sec)
/gettime.php
The time is 12:13:47pm
Timezones match at Europe/London
PHP 7.4 Running on a Pi - Bullseye
tried running ./caily.php and no change, rebooted no change

Same here system and mariadb time are same.

image

Hello,

Was the timezone set according to the installation documentation?

Yes. I Have been using Libre for 1 year, this error is a 2 - 3 days old.

Just done a fresh install on Ubuntu 20.04 following the instructions. Can confirm php timezone is correct but getting this validation error (despite select now(); ) showing the correct time.
In BST timezone.

In my production environment I am using the release version, there is no error in validate.
After updating my test environment, validate presented the error mentioned above by the other members.
I have reviewed all my time and timezone settings and they seem to be correct.

@murrant , could the PHP dependency updates made in these commits Update PHP dependencies (#14028) · librenms/[email protected] · GitHub influence this error?

Also confirmed to have the same issue. It also is complaining about my ServerName being wrong in Apache which is set at the global and the vhost level. It looks to be something new that was introduced which prompts me to check validation every week since something always breaks from a daily update

I have had the same issue since I upgraded to version 22.5.0-41-g3e547de95 - Fri Jun 10 2022 19:50:33 GMT-0600 on Friday June 10th. I had not had this issue previously, and the /etc/php/7.3/fpm/php.ini and
/etc/php/7.3/cli/php.ini are properly set

I have been using Libre for five months, it is very good
before 2 - 3 days ago,all validate status is ok
after last weekend,today I go to office,it shows this error

Can you give an example of what your server name is and what LibreNMS thinks it should be?

RRD and MySQL validations have been fixed upstream.

Sure. In my apache configuration:

<VirtualHost *:80>
 ServerName librenms.fqdn
 Redirect / https://librenms.fqdn
</VirtualHost>

<VirtualHost *:443>
  ServerName librenms.fqdn
  DocumentRoot /opt/librenms/html/
  SSLEngine on
  SSLCertificateFile /etc/apache2/ssl/librenms.cer
  SSLCertificateKeyFile /etc/apache2/ssl/librenms.key
  AllowEncodedSlashes NoDecode
  <Directory "/opt/librenms/html/">
    Require all granted
    AllowOverride All
    Options FollowSymLinks MultiViews
  </Directory>
  # Enable http authorization headers
  <IfModule setenvif_module>
    SetEnvIfNoCase ^Authorization$ "(.+)" HTTP_AUTHORIZATION=$1
  </IfModule>

  <FilesMatch ".+\.php$">
    SetHandler "proxy:unix:/run/php-fpm-librenms.sock|fcgi://localhost"
  </FilesMatch>
</VirtualHost>

I have this set in my virtual host config file and in the global apache file. I tried doing both based off the fix of what the validation error complains about but the web UI always fails the check. ./validate.php -g webserver comes out OK.

$ ./validate.php -g webserver

Component Version
LibreNMS 22.5.0-47-g898061403
DB Schema 2022_05_30_084932_update-app-status-length (242)
PHP 7.4.13
Python 3.8.10
MySQL 10.3.34-MariaDB-0ubuntu0.20.04.1
RRDTool 1.7.2
SNMP 5.8

====================================

[OK] Composer Version: 2.3.7
[OK] Dependencies up-to-date.
Checking webserver: OK

thank you
today,I run ./daily.sh,RRD and MySQL validation errors have disappered

The problem with a different time between the server and the MySQL DB is solved, but now I’m getting the following error when validate:

FAIL: server_name is set incorrectly for your webserver, update your webserver config.

this happened with two different installations on different locations. The server name is configured correctly.
Nothing was changed, no one touched the configuration of LibreNMS or the web server and they’re both running for the last two years with no issues.

Any idea?

This is a new validation. It may not be 100% correct yet. Help figuring out if it is wrong and how it is wrong in that case would be very appreciated.

Took a guess at the validation issue (the :80 or :443 showing up sometimes).

Looks to have corrected the issue. Thank you!