Validate failure after upate

After the latest daily update, I’m getting a failure in my validate config. When running the validate from the web gui, I get this message:

I have restarted Apache and still get the validate error.

When I validate from the CLI, I get no errors.


Component Version
LibreNMS 1.63-126-g3c4751e3c
DB Schema 2020_04_06_001048_the_great_index_rename (165)
Python 3.6.9
MySQL 10.1.44-MariaDB-0ubuntu0.18.04.1
RRDTool 1.7.0

[OK] Composer Version: 1.10.6
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct

Then update your apache mod version to match the cli version :wink:

So, I’m not a Linux guy. I don’t know what “mod version” and “cli version” is or why there would be two versions of the same application in use here or how to change either one.

PHP comes in a module variant, for your Apache Web server, and as a CommandLine Interface variant as well. Both version should match.
For some reason, only CLI was updated at some point, not the module. So you have to find out why and fix it. This is a fairly new test in validate, so the issue is not necessarily new, just validate was not checking.

This is a possible solution, I had what seems to be a similar issue and following steps fixed it for me. Insert “sudo” where applicable.

1: Figure out which version of php you ran prior to the upgrade.

2: Figure out which version of php you are running now:
dpkg -l | grep php7.

3: Disable the old php mod for apache2.
a2dismod php7.X

4: Enable the new php mod for apache2.
a2enmod php7.X

5: Restart apache2:
systemctl restart apache2

6: Verify status & validate:
systemctl status apache2
apache2ctl configtest
Validate both cli & gui.