./validate/php cannot find module//cannot adopt OID

So I’m having an odd issue with ./validate.php
Let me start over…
I installed librenms on Ubuntu 18.04, used these instructions to do it https://docs.librenms.org/Installation/Installation-Ubuntu-1804-Apache/
I have it up and running, but when I go and do a ./validate.php, I get pages and pages of errors.
Right now, it’s graphing and seems to be working, but I’d like to find out why the validate process fails. Any ideas?


This is because you have imported some MIBs with errors (or in a way that causes errors) in your /etc/snmp.conf file. I suggest you just remove that file.

There is no file /etc/snmp.conf
But I do have /etc/snmp/snmp.conf
Here is the contents of that file, as the instructions said…

Change RANDOMSTRINGGOESHERE to your preferred SNMP community string

com2sec readonly default “mysnmpcommunityhere”

group MyROGroup v2c readonly
view all included .1 80
access MyROGroup “” any noauth exact all none none

syslocation Rack, Room, Building, City, Country [GPSX,Y]
syscontact Your Name “myemailadresshere”

#Distro Detection
extend . distro /usr/bin/distro
#Hardware Detection (uncomment to enable)
#extend . hardware ‘/bin/cat /sys/devices/virtual/dmi/id/product_name’
#extend . manufacturer ‘/bin/cat /sys/devices/virtual/dmi/id/sys_vendor’
#extend . serial ‘/bin/cat /sys/devices/virtual/dmi/id/product_serial’

Yeah, I meant that file. Those contents should be in /etc/snmp/snmpd.conf NOT /etc/snmp/snmp.conf…

I’m sorry, that was a typo. That file I pasted IS the snmpd.conf file under /etc/snmp/snmpd.conf