Validate.php errors - could someone advise on how I fix them?

Hello,

We have a LibeNMS server and 2 Docker pollers. All 3 poll around 2k of devices.

I ran the validate script recently and have these issue below, could someone advise on how I fix these?

====================================
Component | Version
--------- | -------
LibreNMS  | 22.9.0-3-g06c361c2b
DB Schema | 2022_09_03_091314_update_ports_adsl_table_with_defaults (246)
PHP       | 7.4.3
Python    | 3.8.10
Database  | MariaDB 10.3.34-MariaDB-0ubuntu0.20.04.1
RRDTool   | 1.7.2
SNMP      | 5.8
====================================

[OK]    Composer Version: 2.4.4
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database Schema is current
[OK]    SQL Server meets minimum requirements
[OK]    lower_case_table_names is enabled
[OK]    MySQL engine is optimal
[OK]    
[OK]    Database schema correct
[OK]    MySQl and PHP time match
[OK]    Distributed Polling setting is enabled globally
[OK]    Connected to rrdcached
[WARN]  PHP version 8.1 is the minimum supported version as of September, 2022. We recommend you update PHP to a supported version (8.1 suggested) to continue to receive updates. If you do not update PHP, LibreNMS will continue to function but stop receiving bug fixes and updates.
[FAIL]  Missing PHP extension: memcached
	[FIX]: 
	Please install memcached
[OK]    Active pollers found
[OK]    Dispatcher Service is enabled
[OK]    Locks are functional
[OK]    Python wrapper cron entry is not present
[OK]    Redis is functional
[OK]    rrdtool version ok
[OK]    Connected to rrdcached
[WARN]  Your install is over 24 hours out of date, last update: Thu, 29 Sep 2022 04:32:10 +0000
	[FIX]: 
	Make sure your daily.sh cron is running and run ./daily.sh by hand to see if there are any errors.
[WARN]  Your local git branch is not master, this will prevent automatic updates.
	[FIX]: 
	You can switch back to master with git checkout master
[WARN]  Your local git contains modified files, this could prevent automatic updates.
	[FIX]: 
	You can fix this with ./scripts/github-remove
	Modified Files:
	 includes/definitions/rutos.yaml
	 poller-wrapper.py
	 rrd/.gitignore

I have run the daily.sh

./daily.sh 
Updating to latest codebase                        OK
Updating Composer packages                         OK
Updating SQL-Schema                                OK
Updating submodules                                OK
Cleaning up DB                                     OK
Fetching notifications                             OK
Caching PeeringDB data                             OK
Caching Mac OUI data                               OK

If I run the validate.sh it says I haven’t run the daily.sh for 24 hours still which is odd.

Any advice would be great. I thought I had memcache installed, how do I check and install?

Thanks

Fixed

Upgraded Ubuntu 20.04 to 22.04