Version 21.3.0-62-g43ea55bcf not showing devices although successfully added

Tags: #<Tag:0x00007f6cb00a9000>

I am sitting on this sice 3 days for many hours.
I firstly tried to get LibreNMS running with jarischaefer/docker-librenms docker container in combination with the official mysql as well as with the official MariaDB container. Both ended with a running LibreNMS where validate is only complaining about warnings in missing update possibilities which are caused by the docker image and its standard behaviour.
I then tried to use a MariaDB on the host with the original LibreNMS docker container as well as with a MariaDB as a docker container. All tries so far ended in no critical errors in validate with a full functioning web interface. I can add devices, and delete them. They were polled and the they were displayed as long as I clicked the link directly after adding the device. In the main menu at “device” there is always “no devices”. I logged in into MariaDB and got the devices table where my device was existing. If I get into the device dependencies menu I can get a direct link to the functioning particular details page. Only under “devices” there is always “no device”.
I also tried to use another MariaDB on a Synology NAS to change the device for SQL as well as using an older Container/LibreNMS Version (21.2.0). No change.
Finally I installed LibreNMS with the official instructions from the LibreNMS install guide for Debian 10 on a Raspberry Pi 3. https://docs.librenms.org/Installation/Install-LibreNMS/
This time validate prints all green OK. But the same behaviour occurs.
Now im sure thats not my fault. But whats wrong? It looks like the website is unable to load the device list to fill the devices dropdown, because on other places in the website (like deleting or the dependencies) I can select the device and delete it as well as get to the details-Page of the device.

Greetings,
Tekknologgy
(Network-Admin at a big infrastructure company)

Sounds like discovery is not running

I dont know what you mean with that…
On so much different systems with different versions and different components I would say that if I add a device it should be listed under the devices without taking some special actions…
As I mentioned, I am a network administrator. So I know different systems like LibreNMS which monitor components. If I am right, autodiscovery scans my network and tries to get systems into polling with previously added standard SNMP communities and/or login credentials. Im not interested in autodiscovery. I wish to add devices manually and monitor them. Thats what I did. I added them manually and I can get to the details page of the devices, but they are not listed in the normal way under “devices” but they are listed when I am going to delete a device or when I go to the dependencies page.

Hi @Tekknologgy
I would like to say that you skipped some step during the install, but I cannot see which one really. Never had a single issue with finding a device that I just added in multiple deployments.

Using the search menu, do you find it ?
Is the user you use to log into LibreNMS an admin user ?

The user I used is the initial admin user which was created during web based install wizard.
nah. If I skipped some step during install process: always the same in different setups?
I mean: I firstly used jarischaefer/docker-librenms docker container… I used his docker dokumentation. Then I used the librenms/librenms container with the setup instrucions on Github. I thought it maybe was some setting in table collations or something else. Or maybe a incompatibility in mysql aka mariadb… But after I tried diefereent combinations and all gave the same behaviour…
I then decided to try to setup a LibreNMS installation plain on a machine without docker. The easiest was to setup it on a raspberry, because I always have one running to play…
Now I could say maybe its because ARM architecture, but the same behaviour? Really? This cant be, I think…
Finally I could test it another time with apache under a ubuntu environment in a virtual machine…
I saw there are also detailed setup instructions from librenms website.
Maybe it is caused by nginx… I always used nginx as webserver…
I try that and report it here. But when this dont run, I give up…
By the way. I previously used jarischaefers docker container on my synology nas with my synology mariadb till something was broken in a db file. I decided to setup a new updated container on another machine to free up my nas. So I also have knowledge of installing/maintaining a LibreNMS setup…

Before I started to prepare a virtual Ubuntu 20.04 Machine, I had the idea to look into the “/opt/librenms/logs/librenms.log”. There is no Error.
The first entries in the file are only lines like this:
/opt/librenms/discovery.php new 2021-04-04 17:10:05 - 0 devices discovered in 0.012 secs
This is because I firstly activated SSL before I added the first device.
After I added my synology there were always 2 lines at one until the end of the file.
/opt/librenms/discovery.php new 2021-04-06 17:15:02 - 0 devices discovered in 0.015 secs
/opt/librenms/poller.php 1 2021-04-06 17:15:09 - 1 devices polled in 4.960 secs
This also shows that autodiscovery isnt running, but that 1 device is added and polled.
I planned to include a screenshot of the devices tab and one of the deleting page in this post, but I noticed that the devices tab now lists the device. So I looked up the other web interface on my docker container and there the device is also listed.
So it seems that the device needs quite much time to appear in the devices tab. Too much time in my eyes. Hours or even days… I cant say…
I stopped preparing a virtual Ubuntu now.
Any ideas?

What user are you logging in with? Is it an administrator? Normal users don’t have access to devices unless explicitly granted.

as I already posted, I used the initial admin user. Always. Since I have the problems right after a fresh install…

@Tekknologgy
/opt/librenms/discovery.php new runs every 2 days if your logs are correct here. This one is expected to run every few minutes. It takes care of discovery new devices after they have been added. Every 5 to 30 minutes would be good. It does nothing unless a new device was added/discovered in the last interval.
Normal discovery (the regular one) usually takes place once a day, during the night, for every device.
And poller occurs regularly (5 minutes).

Sorry, that I needed so much time to replay…
I fear you misunderstood me. In the aftermath I understand why.
I meant there are always these two lines until the end of the file.
Discovery runs all 5 minutes. Same as the poller.
I tried only to say that, the synology was recognized after adding and were polled normally.
But discovery never says that it has found a device…
Now, 6 days after the logs are gone and I cant post them anymore. Sorry.
The system I installed on a Raspberry is still running. I could add another device If someone has an idea what I could try, too…

Normal discovery should not run that often. Because discovery usually take a lot more than 5 minutes to complete.
So :

  • /opt/librenms/discovery.php new every 5 to 30 minutes should be safe, as it only discover “new” devices
  • Normal discovery: every night is standard, you can go up to 2 or 3 times a day.
  • Poller: Every 5 minutes by default, and must match your RRD interval (5 minutes by default)

With this setup, everything will be discovered as expected.