Weathermap editor doesn't open

Hi guys,
I’m running the VM librenms and I’ve followed those Weathermap instructions:

1. Extract to your LibreNMS plugins directory html/plugins so you should see something like /opt/librenms/html/plugins/Weathermap/
  The best way to do this is via git. Go to your install directory and then html/plugins.
    git clone
2. Make the configs directory writeable by your web server, either chown apache:apache configs/ or chmod 777 configs.
  I'd highly advise you choose the first option, replace apache:apache with your web servers user and group.
3. Enable the plugin from the LibreNMS Plugins -> Plugin Admin menu.
4. Create your maps, please note when you create a MAP, please click Map Style, ensure Overlib is selected for HTML Style and click submit.
5. Also, ensure you set an output image filename and output HTML filename in Map Properties.
  I'd recommend you use the output folder as this is excluded from git updates (i.e enter output/mymap.png and output/mymap.html).
6. Enable the cron process by editing your current LibreNMS cron file (typically /etc/cron.d/librenms) and add the following:
    */5 * * * * root /opt/librenms/html/plugins/Weathermap/map-poller.php >> /dev/null 2>&1
7. If you need to, set $basehref within map-poller.php if your install is in another directory than standard.

Perviously the plugins showed a permission error. This is now gone and I get the following:
" Click here to access the editor where you can create and manage maps."
When i click it, the editor doesn’t open. it says page cannot be open.

Any idea how to fix this ?

Sounds like you didn’t place weather map in the correct directory or still have permission issues. Also not sure why you are using the git hub and not the docs from

What do the webserver logs tell you?
Should be /var/log/nginx with the appliance…

When i follow this guide i get stuck at step 5.
Chrome can’t open the editor. I’ve tried re-installing chrome.

Not sure if if the following error has to do with the issue:

Here is the cron file edited:

I’ll look at the log and report it soon.

It’s not related, but you still need it to be fixed. Have you tried running discover manually?

I don’t think the log says that much. In the meanwhile i tried opening the weathermap editor in firefox with no success.

There must be a way to verify the setup somehow.

So there are 2 clear errors here - an unexpected ; and an unknown directive (ie most likely wrong placement of or the // in fastcgi_param).

If you want to comment sth out use #. If you want to give a path, a single / is needed.

I think they aren´t relevant as there is no even ¨fastcgi_param¨ in the script.
This script comes with the IMAGE made by librenms.
Here is a portion of the output of sudo nano /etc/nginx/conf.d/librenms.conf : lines 11 - 15

 location ~ \.php {
  include fastcgi.conf;
  fastcgi_split_path_info ^(.+\.php)(/.+)$;
  fastcgi_pass unix:/var/run/php/php7.0-fpm.sock;

Can you post the rest of the file?
Maybe there is an issue with one of the includes?

I´ve given up the image version as it takes long time to figure out what´s already installed and what isn´t.

I´ve decided instead to install librenms manually.