Web UI not writable with admin account


#1

Hello,

My setup is with Ubuntu server 18.04

This is a fresh install I did last night, everything is working except it seems I can’t modify anything in the web interface. All automated processes work, and I can view them fine but can’t seem to change anything with my admin account. I tried doubling the php-fpm RAM from 128 to 256, no luck. This is an example screenshot when I try to update the dashboard that gives an empty string error:

Also includes the validate output (sorry for the screenshot I’m using windows 10 integrated bash and they haven’t got the copy paste working in the version I have):

The one error you’re seeing I ran the suggested commands already


#2

I am having the exact same issue on 18.04 with a new install. Have not yet been able to figure out the issue.


#3

Do you see the empty error popup too?

After you get the empty error do you see anything in your web browser javascript console or in logs/librenms.log

Can you Edit any settings under a device or edit a user ?


#4

I get no specific errors in the console (only Gridster is not defined, which I assume is not related since it’s on page load) and nothing in librenms.log except polling info. I can successfully make edits to a device, and I can edit my user. I’m also unable to mark notifications as read.


#5

What install guide did you both follow do you have a link?

Can you change this to false in your config.php
$config['secure_cookies'] = false;

set this in your /opt/librenms/.env file
APP_DEBUG=true

Then try it in a different web browser, go to URL/settings/sub=webui/debug=yes/
and try change png to svg under graph settings, same problem ? any more information?


#6

This was the install doc I followed: https://docs.librenms.org/Installation/Installation-Ubuntu-1804-Nginx/

After the steps you suggest, when I try to change png to svg I see this in the console: SCRIPT5009: ‘data’ is not defined - librenms.js (128,16)


#7

I suspect you have incorrect permissions for your php session directory.


#8

Definitely not it, I changed the permissions to 777 temporarily for /var/lib/php/* (along with the folders in the path), restarted nginx and php7.2-fpm and no change.


#9

Did you install on Windows subsystem or are you using that to ssh into your server? If you installed on WSL then chmod and other permissions probably won’t work by default how you intend due to limitations.

no success in a different browser?

do you see the javascript code in your browser when you go direct to:
https://URL/js/jquery.min.js

php7.2-json php7.2-mbstring were installed?

Go back to inspect element click network and compare highlighted values from Request Headers, when you change from svg to png. is it similar?


#10

No, this is installed on a vm I just use the windows subsystem for sshing to it. Yes, both php7.2-json and php7.2-mbstring are installed, tried to re-install just in case and they’re already newest version.

I don’t even see a request to ajax_form.php in my network tab, but I can see it in the .js file so it seems like it’s erroring before that:

More in the console error:

at Object.error (librenms.js?ver=20190514:129)
    at c (jquery.min.js:4)
    at Object.fireWith [as rejectWith] (jquery.min.js:4)
    at k (jquery.min.js:6)
    at Function.ajax (jquery.min.js:6)
    at HTMLSelectElement.<anonymous> (librenms.js?ver=20190514:116)
    at HTMLSelectElement.dispatch (jquery.min.js:5)
    at HTMLSelectElement.v.handle (jquery.min.js:5)

#11

Can you login to the demo https://demo.librenms.org/settings/sub=webui/ (demo:demo)

and try change it on there, do you get the same issue? To rule out it being client side issue.

Could possibly be gzip compression issue on javascript set by the web server. Although i don’t know much about that, i would check you can access the URL i sent before to jquery and check it looks OK not corrupted or anything. Could always try apache aswell to see if you see any change.


#12

I get the green “Config Updated” popup with the demo


#13

Hello, I have been flowing along on this thread and see the same results as Cora.


#14

I just tested the guide you followed https://docs.librenms.org/Installation/Installation-Ubuntu-1804-Nginx/ , and all works fine.

Did some playing around, and i can replicate your issue when the base_url is set incorrectly in config.php

Is yours the default ?
$config['base_url'] = "/";


#15

I have mine set to the internal IP of the server ($config[‘base_url’] = “http://192.168.1.48”)


#16

the Base URL shouldn’t be the ip address…


#17

Well I just realized the line was commented out, so it’s actually not set at all.


#18

@jjtop25 @Cora did you resolve it now with the base_url ?


#19

Hi, sorry I thought I posted. Yes the base URL did resolve the issue. Thank you so much!


#20

Sorry I forgot to mention, but yes setting the baseurl fixed the issue thank you.