Website error : $response = tap($kernel->handle( $request = Request::capture() ))->send()

Hello,

When i try to launch my librenms webpage i get stuck there :

make(Kernel::class); $response = tap($kernel->handle( $request = Request::capture() ))->send(); $kernel->terminate($request, $response);

When i do ./daily.sh and ./validate.php… all looks good. I’m a bit stuck there…

[email protected]:/opt/librenms$ ./daily.sh
Updating to latest codebase                        OK
Updating Composer packages                         OK
Updating SQL-Schema                                OK
Updating submodules                                OK
Cleaning up DB                                     OK
Fetching notifications                             OK
Caching PeeringDB data                             OK
Caching Mac OUI data                               OK

[email protected]:/opt/librenms$ ./validate.php

Component Version
LibreNMS 21.9.0-27-gbfa200f3f
DB Schema 2021_02_09_122930_migrate_to_utf8mb4 (217)
PHP 7.3.30-1+ubuntu18.04.1+deb.sury.org+1
Python 3.8.10
MySQL 10.6.4-MariaDB-1:10.6.4+maria~focal
RRDTool 1.7.2
SNMP NET-SNMP 5.8

====================================

[OK] Composer Version: 2.1.8
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct

Thank you for your help, all those problems come from my update of ubuntu, from 18.04 to 20.04

Regards.

Sharing the error message would be much more useful.

Hi,
I would like to if I could find it.

Only thing I have is my login page with this message :
make(Kernel::class); $response = tap($kernel->handle( $request = Request::capture() ))->send(); $kernel->terminate($request, $response);

Regards.

It sounds like you haven’t enabled php in your web server maybe?
Follow this guide Install LibreNMS - LibreNMS Docs

I also tought, but i did it :

[email protected]:/home/librenms# a2dissite 000-default
Site 000-default already disabled
[email protected]:/home/librenms# a2enmod proxy_fcgi setenvif rewrite
Considering dependency proxy for proxy_fcgi:
Module proxy already enabled
Module proxy_fcgi already enabled
Module setenvif already enabled
Module rewrite already enabled
[email protected]:/home/librenms# a2ensite librenms.conf
Site librenms already enabled
[email protected]:/home/librenms# systemctl restart apache2
[email protected]:/home/librenms# systemctl restart php7.4-fpm

Hello again,

I am still stuck, i will try things and tell you… but i am about to start from scratch… :frowning:

Ok, i dug deeper in the Install librenms guide and i think that what solved the problem was to re start from the : Configure PHP-FPM part.

Cheers.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.