Website not working after manual update

Hello,

I’ve done a manual update today, and now I cannot even get to the login page on the site.
The update itself had a few errors, summary of what I did as follows:

a) A standard “git pull” would give me two errors regarding conflicts (both of them .gitignore files) , I had to do a “git reset --hard” so I could do the git pull. The git pull itself worked fine.

b) I had some errors/warnings running the daily.sh script, something about Illuminate, Carbon, etc, I can paste the logs if needed, but it worked until the end.

I then did a httpd restart, and now I cannot get the login windows to appear. I don’t have any errors on http log, or /var/log/messages, nothing.

Output from validate also looks fine:

[email protected] librenms]# ./validate.php

Component Version
LibreNMS 1.53.1-23-gfc2f0a4
DB Schema 2019_05_30_225937_device_groups_rewrite (135)
PHP 7.2.19
MySQL 5.5.60-MariaDB
RRDTool 1.4.8
SNMP NET-SNMP 5.7.2

====================================

[OK] Composer Version: 1.8.6
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[WARN] IPv6 is disabled on your server, you will not be able to add IPv6 devices.
[[email protected] librenms]#

Any hints ?

Hello @Francisco_Amaro
You can have a look at /opt/librenms/logs/librenms.log to see if you have any tips there.
Bye

Hi all,

Just an update, I tried a few other options, namely the ones in a past post with the same issue, and I could not get it to work.
Since I didn’t had the time for more troubleshooting, I’ve just recovered the VM from the latest backup, I will make a clone of the VM and try this offline, which, in hindsight, should have been the first option…