Which is the best guide to install on a Raspberry Pi4?

Hello,

I’m looking to install LibreNMS on my Pi4 4GB at home. I’ve used it at work and it’s works well.

The Pi uses armv7 I believe, but cab’t find a guide. I tried the ubuntu nginx guide and nginx failed to start. I will start again.

Thanks

Hi!

Yesterday i was install Libre from this site and it was very simple <3
HOW TO INSTALL
You have documentation and video.

If you have any troubles please come to Librenms discord you will get here help.

Hi Eldriad - that link failed I’m afraid.

I’ve corrected the link @gonzo

Thanks, got right to the end, but got this:
image

Then ran

[email protected]:/opt/librenms $ ./scripts/composer_wrapper.php install --no-dev

And got this

> LibreNMS\ComposerHelper::preInstall

Loading composer repositories with package information
Installing dependencies from lock file
Your requirements could not be resolved to an installable set of packages.

Problem 1
- The requested PHP extension ext-mbstring * is missing from your system. Install or enable PHP’s mbstring extension.
Problem 2
- Installation request for erusev/parsedown 1.7.3 → satisfiable by erusev/parsedown[1.7.3].
- erusev/parsedown 1.7.3 requires ext-mbstring * → the requested PHP extension mbstring is missing from your system.
Problem 3
- Installation request for laravel/framework v5.8.30 → satisfiable by laravel/framework[v5.8.30].
- laravel/framework v5.8.30 requires ext-mbstring * → the requested PHP extension mbstring is missing from your system.
Problem 4
- laravel/framework v5.8.30 requires ext-mbstring * → the requested PHP extension mbstring is missing from your system.
- wpb/string-blade-compiler 3.8.x-dev requires laravel/framework 5.8.* → satisfiable by laravel/framework[v5.8.30].
- Installation request for wpb/string-blade-compiler 3.8.x-dev → satisfiable by wpb/string-blade-compiler[3.8.x-dev].

To enable extensions, verify that they are enabled in your .ini files:
- /etc/php/7.2/cli/php.ini
- /etc/php/7.2/cli/conf.d/10-mysqlnd.ini
- /etc/php/7.2/cli/conf.d/10-opcache.ini
- /etc/php/7.2/cli/conf.d/10-pdo.ini
- /etc/php/7.2/cli/conf.d/15-xml.ini
- /etc/php/7.2/cli/conf.d/20-calendar.ini
- /etc/php/7.2/cli/conf.d/20-ctype.ini
- /etc/php/7.2/cli/conf.d/20-curl.ini
- /etc/php/7.2/cli/conf.d/20-dom.ini
- /etc/php/7.2/cli/conf.d/20-exif.ini
- /etc/php/7.2/cli/conf.d/20-fileinfo.ini
- /etc/php/7.2/cli/conf.d/20-ftp.ini
- /etc/php/7.2/cli/conf.d/20-gd.ini
- /etc/php/7.2/cli/conf.d/20-gettext.ini
- /etc/php/7.2/cli/conf.d/20-iconv.ini
- /etc/php/7.2/cli/conf.d/20-json.ini
- /etc/php/7.2/cli/conf.d/20-mysqli.ini
- /etc/php/7.2/cli/conf.d/20-pdo_mysql.ini
- /etc/php/7.2/cli/conf.d/20-phar.ini
- /etc/php/7.2/cli/conf.d/20-posix.ini
- /etc/php/7.2/cli/conf.d/20-readline.ini
- /etc/php/7.2/cli/conf.d/20-shmop.ini
- /etc/php/7.2/cli/conf.d/20-simplexml.ini
- /etc/php/7.2/cli/conf.d/20-snmp.ini
- /etc/php/7.2/cli/conf.d/20-sockets.ini
- /etc/php/7.2/cli/conf.d/20-sysvmsg.ini
- /etc/php/7.2/cli/conf.d/20-sysvsem.ini
- /etc/php/7.2/cli/conf.d/20-sysvshm.ini
- /etc/php/7.2/cli/conf.d/20-tokenizer.ini
- /etc/php/7.2/cli/conf.d/20-wddx.ini
- /etc/php/7.2/cli/conf.d/20-xmlreader.ini
- /etc/php/7.2/cli/conf.d/20-xmlwriter.ini
- /etc/php/7.2/cli/conf.d/20-xsl.ini
- /etc/php/7.2/cli/conf.d/20-zip.ini
You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.

php version

[email protected]:/opt/librenms $ php -v
PHP 7.2.9-1+b2 (cli) (built: Aug 19 2018 06:56:13) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
with Zend OPcache v7.2.9-1+b2, Copyright (c) 1999-2018, by Zend Technologies

Tried this too

apt-get install php-mbstring
su - librenms

# as user librenms

./scripts/composer_wrapper.php install --no-dev

I will do some research, but php installed ok.

Problem 1 - You need to install this mbstring it should resolve your problems.
You used command apt-get install php-mbstring but you need to add php version.

I’m not sure why the ubuntu 18.04 + nginx guide didn’t work for you, I literally did a fresh reinstall on my rpi4 3 days ago according to it and everything worked, these are the steps I used:

  • used Etcher to flash Raspbian Buster Lite version on sd card.
  • apt update && apt dist-upgrade
  • proceeded step by step by the official ubuntu 18.04 + nginx guide, prepending sudo to each relevant command
  • until I reached the Set permissions part of guide, where the instructions will fail with an ‘setfacl command missing error’, because acl package is not installed by default on raspbian, apt install acl to fix
  • rest of guide proceeded without error

Hope that helps.

Maybe I will put a fresh copy of Bust on an SD card and try again as I just get:
image

While copying the librenms.conf for nginx from the guide, did you change the server_name librenms.example.com; to actual hostname of your pi? Try that, service restart nginx and then try the browser part of install again at http://<hostname>/install.php. Otherwise I got nothing.