Whoops, looks like something went wrong. Check your librenms.log #3

HI everyone,
I saw other topics about approxymatly the same subject but it doesn’t resolve mine.
I have no access to the WebUI with the Whoops message since yesterday but everything else works, no error anywhere.

What I have done :

  • Change permission
  • restart the server
  • rollback then daily.sh
  • Everything else told in the two recent other topics about the same sbjects.

Output of validate.php:

Component Version
LibreNMS 1.43-61-gc222d0e
DB Schema 267
PHP 7.0.30-0ubuntu0.16.04.1
MySQL 10.0.36-MariaDB-0ubuntu0.16.04.1
RRDTool 1.5.5


[OK] Composer Version: 1.7.2
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct

I checked the logs but I didn’t find any weird line between the “device polled” (maybe I have to check somewhere else ?

Any help is welcome.

Installation on AWS instance running Ubuntu 16.04.5 LTS


I got the same issue

Check the librenms.log file and post the error…

You can also set APP_DEBUG=true in .env to to see the error in the webui. Don’t leave that enabled though.

“in .env” where is this environment stored?

In the install dir. Default /opt/librenms

Thanks for the tips for the .env file :slight_smile:
I had it working by changing the update channel to “realease” and force the update via daily.sh.

It’s now working as I had to but I will try to roll back and make it works by searching the issue.

Have a nice day