Yet another HTTP 500 after update

So after the latest update I am now getting the 500 error when I do a debug=yes. Prior to that I noticed polling issues. I have searched through the forums and tried a couple of things listed.
[[email protected] librenms]# ./validate.php

Component Version
LibreNMS 1.43-82-gcf31776
DB Schema 267
PHP 7.1.21
MySQL 5.5.60-MariaDB
RRDTool 1.4.8
SNMP NET-SNMP 5.7.2

====================================

[OK] Composer Version: 1.7.2
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[FAIL] Missing PHP extension: mysqlnd
[FIX] Please install mysqlnd

So I tried installing php-mysqlnd and:

Resolving Dependencies
–Running transaction check
—Package php-mysqlnd.x86_64 0:5.4.16-45.el7 will be installed
–Processing Dependency: php-pdo(x86-64) = 5.4.16-45.el7 for package: php-mysqlnd-5.4.16-45.el7.x86_64
–Running transaction check
—Package php-pdo.x86_64 0:5.4.16-45.el7 will be installed
–Processing Dependency: php-common(x86-64) = 5.4.16-45.el7 for package: php-pdo-5.4.16-45.el7.x86_64
–Running transaction check
—Package php-common.x86_64 0:5.4.16-45.el7 will be installed
–Processing Dependency: libzip.so.2()(64bit) for package: php-common-5.4.16-45.el7.x86_64
–Running transaction check
—Package libzip.x86_64 0:0.10.1-8.el7 will be installed
–Processing Conflict: php71w-common-7.1.21-1.w7.x86_64 conflicts php-common < 7.1
–Finished Dependency Resolution
Error: php71w-common conflicts with php-common-5.4.16-45.el7.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Do I remove the php-common-5.4… and try again?

thanks

tk

yum swap php71w-mysql php71w-mysqlnd

Thanks, that with the optimize fixed it. I did get a time out error on the optimize portion however I didn’t get a prompt back so I left it running. Seems to have finished and I’m have access again.

tk