You must run lnms as teh user librenms

I just installed libre on Ubuntu 20.0.4, after installing I ran ./validate.php and it’s telling my Database is out of date and I need to run ./lnms migrate to fix it, but when I try to run that command it gives an error telling me I must run lnms as the user librenms. I don’t recall creating a user librenms. Anyone have any idea’s? I’ve also tried running it as root and got the same error.

networkadmin@ttcscitss12:/opt/librenms$ ./validate.php

Component Version
LibreNMS 21.4.0-6-gd06be3f3f
DB Schema 2020_08_28_212054_drop_uptime_column_outages (174)
PHP 7.4.3
Python 3.8.5
MySQL 10.3.25-MariaDB-0ubuntu0.20.04.1
RRDTool 1.7.2


[OK] Composer Version: 2.0.12
[OK] Dependencies up-to-date.
[OK] Database connection successful
[FAIL] Your database is out of date!
./lnms migrate
[FAIL] You need to run this script as librenms or root

networkadmin@ttcscitss12:/opt/librenms$ ./lnms migrate
Error: You must run lnms as the user librenms

root@ttcscitss12:/opt/librenms# ./lnms migrate
Error: You must run lnms as the user librenms

does su librenms work?

recheck the installation docs you followed, you should have added a librenms user

1 Like

I’m so stupid sometimes…lol

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.