Add support for datacore

DO NOT DELETE THIS INFORMATION.

Please read this information carefully.

GitHub issues is for known/validated bugs, please do not post issues asking for help or how to do X, Y or Z.

You can use our Discord server to ask questions or our community site.

If you have a feature request please post this on our community site.

  • [x] Is your install up to date? Updating your install
    Please do not submit an issue if your install is not up to date within the last 24 hours or on a stable monthly release.
  • [x] Please include all of the information between the ==================================== section of ./validate.php which you can run from the cli.
  • [x] Please provide ALL info asked for here.
Component Version
LibreNMS 1.36-65-gdf724a7
DB Schema 235
PHP 7.0.27-1+ubuntu16.04.1+deb.sury.org+1
MySQL 10.0.33-MariaDB-0ubuntu0.16.04.1
RRDTool 1.5.5
SNMP NET-SNMP 5.7.3

Discovery
Poller
Snmpbulkwalk

I’m using check_sansymphony - plugin for nagios which detects datacore perfectly - here are the results from my datacore server.
Official support for SNMP from datacore

(Imported from https://github.com/librenms/librenms/issues/8249, Original request by: @Friendbg)