Assistance with trying to support new device

Hello,

I’m trying to help myself on this one, but with my knowledge the docs just aren’t getting me there. I assume a new device is something I’ll run across from time to time as I continue to use LibreNMS more and more, so I’d like to learn how to handle this so I can give back in the future.

We have a couple of Dell SCv3000 storage arrays. They get detected as FreeBSD devices, and I can’t see any relevant stats like disk usage, iSCSI traffic load, etc. Dell has a MIB available for download so I headed over to the new OS support section of the LibreNMS docs and gave it a try.

When I run the new-os.php script, I get an error similar to the following, no matter which table I choose to include: https://p.libren.ms/view/7a0f5585

I’m not sure where to go from here. This is the second time I’ve tried to add a new device and I’ve hit the same problem both times.

Thanks!

Looks like you need mib2c which is part of net-snmp

1 Like

Ah, thank you! It seems on Ubuntu 18.04 you have to install the libsnmp-dev package to have this. I assume there is some other pre-req missing since now I get the following error message. It’s cut off so I’m not sure exactly what it’s missing.

In Parser.php line 424:

Unable to parse at line 3 (near “this by getting the latest source release of the net-snmp toolkit from”).

I got past the additional error by installing the libsnmp-perl package.

I’ve worked through and tried to add temperature sensors for starters. I’m not sure if I’m filling the right values in when I’m running the script though. After I’m finished, if I rediscover the device in LibreNMS it is still showing as BSD/generic.

Screen capture of my new-os.php script here: https://p.libren.ms/view/cbebeef9

Re-run of discovery: https://p.libren.ms/view/3c2f4674

Slow progress, but progress. I’m detecting the device properly now, configured to read the temperature sensors. I’m getting graphs, but need to tweak the labels on them and am not sure of the syntax.

The system has two redundant controllers, and the labels are coming out the same for each controller.

snmpwalk of scCtlrTempEntry: https://p.libren.ms/view/8de482e6
includes/definitions/discovery/scos.yaml: https://p.libren.ms/view/f02a4ca3
Several of the graphs have the same name, unable to tell if it’s from controller 1 or controller 2, like in this sample image:

Updated scos.yaml as follows, seems happier:

descr: ‘Controller {{ $subindex0 }} - {{ $scCtlrTempName }}’

So with your recent progress in mind do you think the current manual is sufficient?
I tried to do it before and failed too, so maybe if you have documented your activities that could be shared às a successfull example?

Cheers

Hi RandGH,

I keep making little bits of progress, but then run into a different issue. The documentation might be lacking a little but I think most of my issues were a basic unfamiliarity with the code base and where to look to figure out why something isn’t working… Plus I’m a total hack at PHP so the complexity of the code is just generally a little difficult for me sometimes.

I think half the problems I’ve had are due to the fact that this is a complex device that doesn’t necessarily present its SNMP info in a consistent/expected manner. I’ll gladly share my notes with you, but I’m not done yet. If I can figure out the whole github thing, I’d like to push my code back to the community once finished so they’ll have SCv support out of the box.

Regards!

Hi Whysyn,

Did you get this Dell Compellent setup?

I’m trying to do the same with a few different models, but having problems with the new-os.php script.

Any pointers would be appreciated.

thanks.