Change to PHP minimum version >= 5.6

Following on from Proposal for changing required PHP version to 5.6

We are trying to give users enough prior notice about the change to the minimum version that LibreNMS will support going forward. From the 10th of January we will move from support PHP 5.3 as a minimum to PHP 5.6 or above (PHP 7 recommended as always). We’ve canvased opinion on this before and had little feedback, a survey we did mid 2017 showed that PHP versions less than 5.6 make up a small percentage of what users run. Numbers from the stats users can opt in shows PHP versions < 5.6 at around 13% which some may say is still a high percentage.

Overall, the global trend shows that PHP installs < 5.6 is continuing to decline.

We already have a number of work arounds in place and old libraries that we have to use to maintain support for PHP < 5.6 and it’s about time we updated the packages we use. It will also lead us into being able to use more off the shelf packages so we can continue to enhance LibreNMS.

Since 1.33 and master release 10 days ago, if you’re running PHP < 5.6.4 you will now start seeing validate warnings and logs about this. We would highly advice you to update your PHP version before the end of the year with PHP version 7 being the recommended.

We will add links to articles and tutorials on how to install a more recent version of PHP on distros that natively don’t support newer release.

To clarify, from the 10th of Jan, the min version of PHP that LibreNMS will support is 5.6.4. If you run the stable release then this will be from version 1.36.

NOTE: LibreNMS will continue to function on PHP versions < 5.6.4 from the 10th of January but you will no longer receive updates.


Updated PHP stats info:

Less than 10% of people using composer are running PHP <= 5.5 now.