Proposal for changing required PHP version to 5.6

We asked the question about the PHP version everyone runs in our user survey as we have been contemplating for a while now to update the minimum required php version from 5.3 to 5.6. PHP themselves no longer support or provide security updates for anything less than 5.6.

Tracking PHP’s releases isn’t the sole reason for considering this change, over the last 12+ months we have come across numerous changes we’d have liked to have made which haven’t been possible because a 3rd party library themselves have dropped support for older versions of PHP and thus we’ve been forced to either ditch the change or work around it. Our InfluxDB support already has the minimum version set to 5.6 due to our dependancy on a 3rd party library. It’s also worth mentioning that LibreNMS v2 already has a requirement of 5.6.4 so bringing v1 into line will mean you have a better upgrade path to v2 when it arrives. From the feedback and also the stats we collect (samples of 76 and 461 respectively), people using PHP 5.3, 5.4 and 5.5 is around 14.5%. That’s a lot of users and don’t worry, we aren’t just going to make a change tomorrow and leave that many people hanging.

We’ve also been linked to by @barryodonovan on Twitter. This confirms the downward trend in PHP 5.3, 5.4 and 5.5.

We’d still like to gather feedback on this but if we were to go ahead then it would go something like this:

Our plan is to first update the installation instructions to show the minimum version is now PHP 5.6, post notifications on Social media, forums and within your installs and that’s it. The code base won’t immediately cease to work with any lower versions but at that stage we do highly recommend that you plan to upgrade to a newer version of PHP. We recommend PHP 7 due to the additional performance benefits it brings by default.

We will continue to make every effort to ensure that we continue to support PHP 5.3 for as long after as we can. When we get to a release or commit that does in fact break backwards compatibility we will ensure version checks are done so that all that will happen is an install on PHP 5.3 for example will no longer receive updates. It’s quite possible someone will pick up and maintain the branch that would stop being updated by the core team so everyone gets the best of both worlds but this isn’t guaranteed.

In the meantime, please do get in touch and let us know if this will effect you negatively as we’d like to understand the impact of this as much as possible - everyone has a voice.