[Cisco WiFi virtual Controller] Manually add device to Oxidized


I have some cisco virtual controller I’d like to add to Oxidized, but LibreNMS won’t add them to node list.
Please find my setup:

  • Server 1 : LibreNMS VM
  • Server 2 : Oxidized VM
    Oxidized, on Server 2, is feed by Server 1 by using LibreNMS API and token. But as long as a device is not added to node list by LibreNMS, Oxidized can’t backup them.
    I found, in device’s options / misc, a way to exclude a device from Oxidized, but I didn’t find the way to add them manually.

Could you help me ?



Sorry it’s not clear what the issue is here for you, are you feeding Oxidized using the LibreNMS api?

Hello Laf,

I’m sorry for not being so clear as I 'd like to be.
That right, I’m feeding Oxidized with through LibreNMS API like that (part of my Oxidized configuration) :
default: http
debug: true
url: http://my.librenms.srv/api/v0/oxidized
name: hostname
model: os
group: group
X-Auth-Token: ‘mysupertoken’

The node list get by Oxidized is automatically defined by LibreNMS.
I don’t know how to add manually device to the node list.
There is a way to exclude device from Oxidized, but I didn’t find how to add some.
Virtual controller (OS given by LibreNMS == Cisco WLC) seem to be backupable with Oxidized by using aireos.rb.


I have the same issue when a new device is added on librenms. I have to restart the oxidized service to include the new node in the backup process.

@Vincent_LaNetCie So if you add a device to LibreNMS then it will appear in the Oxidized list assuming you haven’t excluded any of the groups or OS types. You will also need to manually map the OS in LibreNMS to the one in Oxidized, if you go to /settings/external/oxidized and add to the Variable mapping section like this:

That should work.


Different issue, go to /settings/external/oxidized and enable Reload Oxidized nodes list, each time a device is added

It appears that does not work if oxidized is on a different server.


I think it doesn’t really work if Oxidized is not on the same server, I have the Reload Oxidized nodes list, each time a device is added enabled.
When I add a new device in LibreNMS I have to access the Oxidized server and restart the service.

Hello Laf,

I’ve tried to apply your advice.
Sadly, my cisco virtual controller are still not present in node list
That said, I’ve checked and my Moxa devices are neither present in node list.
I have no idea why these devices are not sent to the node list.


And, I have no problem with IOS, CiscoSMB, RouterOS, ironware devices.


It at least used to work ok.

The reload to oxidized is only called when discovery first runs against the device so by default this could be up to 5 minutes after you added the device was added to LibreNMS, have you waited that long?

If you run:

curl -k -H 'X-Auth-Token: YOUR_API_TOKEN' https://YOU_LIBRENMS_URL/api/v0/oxidized

Can you see the device in the output and does the info look correct?

Hi Laf,

Yes, the output with curl is good.

It is interesting that when I delete a device, I get this oxidized debug log.

I, [2022-01-28T09:33:40.772544 #995] INFO – : lib/oxidized/nodes.rb: Loading nodes
I, [2022-01-28T09:33:41.251877 #995] INFO – : lib/oxidized/nodes.rb: Loaded 551 nodes

When I added the device back in, waited over 15 min and I see no oxidized “loading nodes” message.

Hello Laf,

Thank you for your help and your time.
Yes, I’ve waited that long. Neither Moxas nor Cisco WLCs appeared in Oxidized.



A fix went into master a few days ago to fix a bug in reloading oxidized that we found, if you are using a stable release you’ll need to wait for middle of this month. If you’re not, make sure you’re upto date and it should be good now.

Hello Laf,

Thank you for the fix !
Yesterday, I’ve added 2 news devices to librenms. A routeros and a ciscosmb. They were added to Oxidized automatically.
I removed one of my wlc then added it back, and it still not shown in Oxidized.


Did you add the OS mapping as I showed earlier in a screenshot?

Hello Laf,

Yes, I’ve added to OS mapping.
I’m using OS mapping for some cisco device that doesn’t support some kind of authentication and that work perfectly. But not for Cisco WLC and Moxa.
I think it’s because OS mapping is working after devices are added to Oxidized.


If you call the LibreNMS api as per this post, do you see the correct OS returned?


I will check it.
Thank you.