Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.3.0"

I ran a bunch of updates on my server and LibreNMS to update the php version and more (not an expert… and unfortunately some of them I didn’t understand what they did, just followed guides.)

Now the WebUI loads with this error:

In the error.log I see that it claims php version is running 7.1.33:
PHP Fatal error: Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.3.0". You are running 7.1.33-10+0~20200220.32+debian9~1.gbpd6a133. in /opt/librenms/vendor/composer/platform_check.php on line 45

./validate.php output shows the php version to be 7.4.30:

====================================
Component | Version
--------- | -------
LibreNMS  | 22.6.0
DB Schema | 2020_08_28_212054_drop_uptime_column_outages (175)
PHP       | 7.4.30
Python    | 3.5.3
MySQL     | 10.1.48-MariaDB-0+deb9u2
RRDTool   | 1.6.0
SNMP      | 5.7.3
===================================

Running php -v also shows that php is on 7.4.30:

PHP 7.4.30 (cli) (built: Jun 14 2022 10:25:43) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies
    with Zend OPcache v7.4.30, Copyright (c), by Zend Technologies

Can anyone suggest what my next step can be to get it back up and running?

Similar issue as Upgrade to Raspbian Bullseye broke LibreNMS install (which didn’t end with a resolution.)

I was able to get this resolved. Seems I was missing was step of the PHP upgrade as guided here Upgrading php7.2 to php7.4 in Ubuntu 18.04LTS

I haven’t had added this to my librenms.conf file:

  <FilesMatch ".+\.php$">
    SetHandler "proxy:unix:/run/php-fpm-librenms.sock|fcgi://localhost"
  </FilesMatch>

All good now. Thanks.