Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 8.1.0"

Hello Guru,
Can you please help me resolving this issue on my end. just upgraded php 7.4 to 8.1 and now I got this error when accessing LibrenNMS. Steps that I’ve done. I’m running in Ubuntu 20.04

#sudo apt install software-properties-common
#sudo add-apt-repository ppa:ondrej/php
#sudo apt-get update

#apt install php8.1-common php8.1-mysql php8.1-xml php8.1-xmlrpc php8.1-curl php8.1-gd php8.1-imagick php8.1-cli php8.1-dev php8.1-imap php8.1-mbstring php8.1-opcache php8.1-soap php8.1-zip php8.1-intl -y

My Php version is already at 8.1.14 when issuing this command

php -v

PHP 8.1.18 (cli) (built: Apr 14 2023 04:39:24) (NTS)
Copyright (c) The PHP Group
Zend Engine v4.1.18, Copyright (c) Zend Technologies
with Zend OPcache v8.1.18, Copyright (c), by Zend Technologies

Hoping someone could help me on this. Thanks

Might be php-fpm, run over the install doco for php-fpm and ensure it’s setup correctly with the new version: Installing LibreNMS - LibreNMS Docs

If it’s php-fpm at fault, you might have success with this shortcut too: Upgrading Ubuntu 20 to Ubuntu 22 and PHP 8.1 - #5 by murrant

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.