Dell OpenManage Disk Failure Status

Is there the ability to graph and provide alerting on Dell OpenManage Disk Failures?

We have dell state support which seems to include some disk stuff, have you looked in health -> state to see?

Yah I looked in health state but unfortunately it only shows cpu, dims and power supplies only. Check a few others Dell Servers and they don’t appear to have any disk information under state either for some reason.

Appreciate the help with this.

pastebin the output of ./discovery.php -h HOSTNAME -d -m sensors

Sure, here you go:

Was there any additional information you needed me to provide?

Your output is showing that the walks for arrayDiskTable and virtualDiskTable are empty.

You could try doing a full snmpwalk and see if you can see the data in that.

I think the data I may be needing for the Array status is these oids. They seem to return appropriate data. - arrayDiskState - arrayDiskRollUpStatus

This is the only feature that is keeping me from fulling moving to this. If you need any help moving this forward I would be glad to help.
snmpwalk -v2c -On -cxxxx X.X.X.X .
. = INTEGER: 3
. = INTEGER: 3
. = INTEGER: 3
. = INTEGER: 3
. = INTEGER: 3
. = INTEGER: 11 “yes it is pulled”

Here is a link to ONMS setup if it helps.

I ran this command: ./discovery.php -h X.X.X.X -d -m sensors

noticed this error:
SNMP[/usr/bin/snmpbulkwalk -v2c -c COMMUNITY -OQUs -m StorageManagement-MIB -M /opt/librenms/mibs udp:HOSTNAME:161 controllerTable]
MIB search path: /opt/librenms/mibs
Cannot find module (StorageManagement-MIB): At line 0 in (none)

Copied the StorageManagement-MIB file from /opt/librenms/mibs/dell/ to /opt/librenms/mibs/
now if finds the disks

What OS is this device?

LibreNMS server is centos 7
The monitored device is window 2012r2

Are you querying the physical server DRAC to get this info? Or the Windows server to get that info? (which probably has some kind of Dell OpenManage software installed)?

Yes i am querying the physical dell server with snmp. The server needs to have Dell OpenManage Server Administrator Managed Node installed.

1 Like

Please put the mib back and try this patch:

wget && git apply 9d740921

Ok it works now. Thanks

Thanks for confirming, I’m submitting it as a fix - when it’s merged you will need to run:

git checkout includes/definitions/windows.yaml includes/definitions/linux.yaml && ./

Did this get submitted? The script won’t work to apply the patch and will not work with out the patch:
error: patch failed: includes/definitions/windows.yaml:3
error: includes/definitions/windows.yaml: patch does not apply

This was added to the live version which makes the patch fail:

bad_hrSystemUptime: true

Fixed patch here is the updated install:

wget && git apply 6bed6744