Fake alerts

So, I am tired getting fake alerts. LibreNMS says me “Host is down”, but it’s not true. Or Service is down…
I turned off check ICMP globaly. How can I increase polling and discovering time? Do you have any idea?

We have 134 hosts and 191 services

Please help!

Have you looked through previous questions like this before? https://community.librenms.org/search?q=false%20alerts

1 Like

I read that
But I always get message: “Device is not polled”. Usually I have 5 devices which are not polled
How to increase polling time? What is default? 5 minutes?

Yes default is 5 min

what is showing down SNMP or icmp?

Right now I have turned off ICMP in config file. I mean I turned off ICMP check 2 weeks ago

Turning off ICMP is not going to fix your problem.
First, you need to figure why you having longer than 5 min poll times.

Do the following -> https://docs.librenms.org/Support/Performance/

Also, post the output of validate.php


$config[‘show_services’] = 1;
$config[‘nagios_plugins’] = “/usr/lib/nagios/plugins”;
$config[‘enable_syslog’] = 1;
$config[‘icmp_check’] = false;
$config[‘poller_modules’][‘ospf’] = 0;
$config[‘poller_modules’][‘applications’] = 0;
$config[‘poller_modules’][‘wifi’] = 0;
$config[‘poller_modules’][‘wireless’] = 0;
$config[‘poller_modules’][‘ntp’] = 0;
$config[‘poller_modules’][‘toner’] = 0;
$config[‘poller_modules’][‘bgp-peers’] = 0;

root@monitor:/opt/librenms# ./validate.php
ldap_init: trying /etc/ldap/ldap.conf
ldap_init: using /etc/ldap/ldap.conf
ldap_init: HOME env is /root
ldap_init: trying /root/ldaprc
ldap_init: trying /root/.ldaprc
ldap_init: trying ldaprc
ldap_init: LDAPCONF env is NULL
ldap_init: LDAPRC env is NULL

Component Version
LibreNMS 1.31.03-43-gf158a56
DB Schema 206
PHP 7.0.22-0ubuntu0.16.04.1
MySQL 10.0.31-MariaDB-0ubuntu0.16.04.2
RRDTool 1.5.5


[OK] Database connection successful
[OK] Database schema correct
[WARN] Your install is over 24 hours out of date, last update: Thu, 14 Sep 2017 05:43:14 +0000
[FAIL] You have no timezone set for php. [FIX] http://php.net/manual/en/datetime.configuration.php#ini.date.timezone
[FAIL] Some devices have not completed their polling run in 5 minutes, this will create gaps in data.
Check your poll log and refer to http://docs.librenms.org/Support/Performance/



you need to fix that

1 Like

Ok. I have fixed it

Ok, now follow the performance docs


I changed ICMP check to TRUE
I added this to MySQL config
innodb_flush_log_at_trx_commit = 0

and I played with /etc/cron.d/librenms - "poller-wrapper.py"
in default it was:
/5 * * * librenms /opt/librenms/cronic /opt/librenms/poller-wrapper.py 16

If I setup:
/5 * * * librenms /opt/librenms/cronic /opt/librenms/poller-wrapper.py 8
it makes the system worse

Now I’ve changed it to:
/5 * * * librenms /opt/librenms/cronic /opt/librenms/poller-wrapper.py 128
It became little bit better (I don’t know is it normal or not)

So we have many remote hosts with not stable connections, we are getting alerts, but I do not understand, why poller cannot recognize our local hosts? Right now I disabled remote hosts, and poller has been identified local hosts. What is wrong?

After all these actions and updating system the widget “Alerts” in dashboard does not update window (only widget). I need every time update tab in browser. What is it.

My librenms config:
$config[‘show_services’] = 1;
$config[‘nagios_plugins’] = “/usr/lib/nagios/plugins”;
$config[‘enable_syslog’] = 1;
$config[‘icmp_check’] = true;
$config[‘poller_modules’][‘sensors’] = 0;
$config[‘poller_modules’][‘ospf’] = 0;
$config[‘poller_modules’][‘applications’] = 0;
$config[‘poller_modules’][‘wifi’] = 0;
$config[‘poller_modules’][‘wireless’] = 0;
$config[‘poller_modules’][‘ntp’] = 0;
$config[‘poller_modules’][‘toner’] = 0;
$config[‘poller_modules’][‘bgp-peers’] = 0;
$config[‘poller_modules’][‘cisco-ipsec-flow-monitor’] = 0;
$config[‘poller_modules’][‘cisco-remote-access-monitor’] = 0;
$config[‘poller_modules’][‘cisco-cef’] = 0;
$config[‘poller_modules’][‘cisco-sla’] = 0;
$config[‘poller_modules’][‘cisco-mac-accounting’] = 0;
$config[‘poller_modules’][‘cipsec-tunnels’] = 0;
$config[‘poller_modules’][‘cisco-ace-loadbalancer’] = 0;
$config[‘poller_modules’][‘cisco-ace-serverfarms’] = 0;
$config[‘poller_modules’][‘netscaler-vsvr’] = 0;
$config[‘poller_modules’][‘aruba-controller’] = 0;
$config[‘poller_modules’][‘entity-physical’] = 0;
$config[‘poller_modules’][‘applications’] = 0;
$config[‘poller_modules’][‘cisco-asa-firewall’] = 1;
$config[‘poller_modules’][‘mib’] = 0;
$config[‘poller_modules’][‘junose-atm-vp’] = 0;

Did you setup RRDCached?

Not yet… I wiil do it

Try RRDCached.

Also, 128 threads for poller-wrapper.py is way too much in my opinion, unless you have the hardware to handle that. If you don’t you are just going to overload the servers CPU’s every poll.
try a more modest number.

ok! I installed RRDCached and changed theads to 64. I do not see any overloading CPU…

Right now it is better, but any way sometimes I have unpolled devices (1 or 2), and they are local. If I disable remote hosts (they are in different continents), it works fine.

One more problem: I have same troubles with services.
openmanage.pl 14m 57s openmanage SNMP UNKNOWN: No response from remote host "172.X.X.X"
ping 49 days, 15h 11m 50s check_ping 172.X.X.X is alive

Or I have message timeout-ping
But this host is local, it is in our server room…
And I am sure, connection is fine. And usually I do not see any alerts from this host

Is it always the same two devices?

Look at the output of the poller log in your webui /poll-log/, see what’s taking the longest.

Yes same… And they take more time for polling (these hosts in Africa, Monitor is in US)

Look at the polling graphs to see what modules are taking the longest then start tuning those / turning some off

So. Thank you for your help!
I turned off almost all poller and discovery modules. After that I turned on only modules which we need on every host.
And We have excellent result!