Got You don't have permission to access /login on this server after enable HTTPs

Hi All,

I’ve enable the HTTPS for LibreNMS and got the error “You don’t have permission to access /login on this server.” but the HTTP still work as normal
Below is my VirtualHost setting. Did someone have the same problem and could how to resolve?

<VirtualHost *:443>
SSLEngine on
SSLCertificateFile /etc/pki/tls/certs/ca.crt
SSLCertificateKeyFile /etc/pki/tls/private/ca.key
<Directory “/opt/librenms/html/”>
AllowOverride All
Require all granted
Options FollowSymLinks MultiViews
</ Directory>
DocumentRoot /opt/librenms/html/
AllowEncodedSlashes NoDecode
ServerName XXXX
CustomLog /opt/librenms/logs/access_log combined
ErrorLog /opt/librenms/logs/error_log
</ VirtualHost>

That’s an apache only error so guess needs the config tweaked a little

Give this one a try

#SSL only applying to Dashboard


Okay, I found the wrong in configuration
<Directory “/opt/librenms/html/”>
change to
<Directory “/opt/librenms/html/”>

Use the " "
Now I can access with https :sweat_smile:

Just a word here. That’s the reason why people should keep their code/snippets formatted correctly.

This char: “
Is not this char: "

I find it very often while cruising around blogs/howtos/tutorials.
Sorry for OT :wink:

1 Like